BeOS5 with 8 procs inside Virtual Machine


#1

Hello,
I was able to get the Pulse Application to see all 8 Processors inside my Virtual Machine:
http://www.rodpeterson.com/beos/BeOS5vSphere6_files/BeOSPulse_error5.PNG

I had trouble when I would increase the vCPUs after the BeOS Operating System was installed. This is what Pulse looks like when I set the vCPU during the install and then changed it to 4 vCPUs later:
http://www.rodpeterson.com/beos/BeOS5vSphere6_files/BeOSPulse_error1.PNG

I then tried setting the vCPUs to 8 during the BeOS install and after a reboot, the Pulse looked great:
http://www.rodpeterson.com/beos/BeOS5vSphere6_files/BeOSPulse_error4.PNG

I even tried setting the vCPUs to 6 during the install, then changed it to 8 vCPUs after reboot:
http://www.rodpeterson.com/beos/BeOS5vSphere6_files/BeOSPulse_error3.PNG

It was fun playing with the settings, but I am glad I finally have all 8 procs showing up in Pulse!
Has anyone ever tried 12 or 16 vCPUs in a BeOS Virtual Machine?

http://www.rodpeterson.com/beos/BeOS5vSphere6_files/BeOSPulse_error6.PNG

Oh, if you want to set up your own BeOS 5 as a Virtual Machine inside VMware vSphere 6, here are my directions:
http://www.rodpeterson.com/beos/BeOS5vSphere6.htm


#2

Not too surprisingly, BeOS had hard coded arrays and bitsets with size 8 to keep track of the processors. So 8 is the most you can use. Odd though that it snapshots the number of processors at install time for GUI purposes, or maybe that’s just Pulse (try finding its settings file and deleting it).


#3

Awesome screenshots, so nice to see 8 processors in Pulse under BeOS! What about the sound? Did it work properly in the virtual machine?


#4

I’m running vSphere6, but I never tried audio through a VM. I will have to give that a try…


#5

Well, sound doesn’t work in VirtualBox since their SoundBlaster emulation has been broken for ages (not just BeOS has stuttering problems). I don’t know about other VMs.


#6

Sound doesn’t work for me in Workstation Pro, either. I guess it’s just passing through my Realtek High Definition Audio.


#7

I have managed to install BeOS 5 on my ESXi machine as well, but I am struggling to get the network working. How do you get the driver files for the network card on the VM?


#8

Make a virtual disk drive, formatted with MS-DOS. Copy the files to it using a different OS with working networking (a live Linux virtual CD-ROM like Knoppix works). Then add it to the Haiku VM.


#9

[quote=“agmsmith, post:8, topic:7305”]
Then add it to the Haiku VM.
[/quote]You meant BeOS, right?


#10

Right, should be add the MS-DOS disk to the BeOS virtual machine. Then mount it in BeOS and copy the files out of it. Use a .zip file to transfer files that need BeOS attributes (icons, e-mail, People files).


#11

Sound works fine for me in VirtualBox using “ICH AC97” audio. (I’m listening to streaming audio on it right now.)


#12

I burned a cd with a bunch of files I wanted to use: video clips, drivers, patches, etc…
Then I put the the disc into the vsphere 6 host, then modify the VM settings : use the host CD drive.
Start the VM running BeOS, and it might auto-mount (depending on your settings). If not, right click on the BeOS desktop, drag to “Mount”, select your disc.
Then you copy your files down.

This Virtual Network Driver for BeOS works in VMware: http://www.vi-tech.org/beos.html
I also have the same files on my website: http://www.rodpeterson.com/beos/Drivers/VirtualNICBeOS.zip


#13

Not for me in BeOS, audio starts working but as soon as you change settings, it stops, and then hangs when rebooting. AC97 does work fine for Haiku.


#14

Finally managed to get the vlance driver installed by creating an ISO (under Windows with the IsoCreator tool from https://sourceforge.net/projects/iso-creator-cs/). I did not manage to get a floppy drive recognized by BeOS. It does see it, but it can’t read or format it.
Does anyone get the mouse to work properly in the browser console of ESXi? I can only get clicks to register, but no mouse movement. I have to use VMWare Remote Console for Windows to manage it. I was hoping I could manage it all from Haiku.


#15

Do NOT use the vSphere Web Client because the mouse won’t work and the keyboard is choppy.
You must use the Traditional vSphere Client that is installed on your workstation. The mouse does work through that client.


#16

Did some more testing. Pulse apparently saves the size of the window in its settings. If you change the number of processors in ESXi you should remove the settings file and it will have a proper size the next time you run it.

While playing with the number of processors for BeOS I noticed that giving it more than one processor causes the vm to use a lot of CPU although Pulse does not see anything being used. Does anyone else have that as well?