BeOS Daylight Savings Question


#1

How can I update Daylight Savings so the the correct Dates change the time in BeOS? Is there a patch? Thanks, Ron


#2

My BeOS system adjusted to standard time automatically.
If you’re referring to the change in dates in the US a few years ago, there is a timezone patch. Let’s see if I can figure out how to attach it…
nehh – apparently it doesn’t like zip files…!
OK I’ve put it on my website instead:

http://www.goodeveca.net/beos/newpdt_BeOS.zip

Hope that’s what you wanted…


#3

I just copied the time zone information files from a Linux system to replace the old ones in BeOS. You may find them in /usr/share/zoneinfo, depending on the Linux distribution. In BeOS they are in /boot/beos/etc/timezones.


#4

[quote=“agmsmith, post:3, topic:4397, full:true”]
I just copied the time zone information files from a Linux system to replace the old ones in BeOS.[/quote]

I think that’s probably what I did originally, though I may have
recompiled from text. (Thanks for pointing out where they should be put! Forgot to specify that…:slight_smile:)


#5

Sweet, Thank You Two I really appreciate your help!!! Ron


#6

Well it all went well I thought. The time changed correctly at first but for some reason the time went back 1hr a couple of weeks later!! I tried zdump but that command does not work. Is there another command or what did i do wrong? Thanks Again, Ron


#7

Maybe you dual booted some other OS (like Windows 2000) that has the older daylight saving time trigger days and it modified the clock? Try the “date” command in Terminal and see if it says the correct time zone and daylight savings. Mine says Eastern Daylight savings Time: Wed Mar 29 14:31:18 EDT 2017


#8

Wow, fast response. No dual boot. I did date in terminal and Output= Wed Mar 29 14:05:43 CDT 2017.
Strange huh… Thanks


#9

The Centos machine I pulled the zone files out of is working fine. Ron


#10

CDT is Central Daylight Savings time, is that correct for your location and legislation (daylight savings is set by your politicians)? Reset your system clock from an Internet time source, a program called NetworkTime does that (though it’s buggy - doesn’t handle errors well), and see if that is then the correct time.


#11

Yep, I’m in Central Time Zone. Tried NetworkTime but it get response "Waiting for answer failed. No such file or directory. List shows time.nist.gov , time-a.nist.gov etc.


#12

Ok, no DNS set in Beos. Added 216.229.0.179 to list and it updated time. The correct time came back as what I had ± seconds


#13

Maybe the time zone file is bad, try a different one from a nearby country which may be in the same time zone. Or get a fresh copy of the zone file from a Linux system (one which is up to date with the latest changes).


#14

Thank You for all Your Help!! Ron