BeOS 5.0 (not Haiku) error

I’m trying to install BeOS 5.0 on a Pentium 3 motherboard, Intel i810e chipset. Booting from the install CD halts at the disc icon, with the following appearing at the point of the halt:

get_module(busses/ide/generic/v0.6): wake failed
get_module(bus_managers/ide/v0.6): wake failed

I’ve also tried BeOS Max Edition 4b, Dano, and the Developer Edition 1.1, all of which halt at the same point. The Zeta 1.2 CD boots all the way with no issues. I tried disabling each of the Safe Mode options one by one but still get the same error. The aforementioned BeOS CD’s will boot all the way if I use the general Safe Mode option. I’m thinking it has something to do with IDE drivers. Does anyone have an idea of what the issue is? If I can install BeOS from the CD in Safe Mode, I could hopefully add an updated IDE driver, maybe using a Haiku CD to move the updated driver to the BeOS partition. I wouldn’t be able to use a USB stick in BeOS in Safe Mode since the USB patches only work with user add-ons which Safe Mode disables.

1 Like

You can attach the physical disk to a virtual machine, install the OS there, add the additional stuff and then boot from the disk.

OP is trying to install to a physical machine… why mention VMs at all? Oh yes I see what you mean… just to get it installed.

You might be able to put the Zeta drivers in BeOS but… why not just run Zeta 1.2 anyway if it works. The Haiku drivers have probably diverged too much to work on BeOS 5.0. There are some old drivers that still did work on Haiku from BeOS a few years ago though (longrun transmetta driver etc…).

I’ve never seen this specific error for 5.0, but in times when I can’t get an older system to boot the CD I would take the hard disk to another machine, do the install there, and return the hard disk upon finishing the installation. BeOS doesn’t do like windows would often do and totally meltdown from being installed in this manner.