Batch of troubles with HaikuPorter "`Failed to find a match" and "`Name not found"

Hi people,

I setup Haiku (hrev51090 gcc2_hybrid) on VirtualBox to build packages with HaikuPorter: I precisely followed all instructions here: Building packages with haikuporter.

As first, i’d wished to build mplayer_X86. As stated here mplayer 1.1.1-3 issue on haikuport’s GitHub the mplayer package needs to be rebuilt: ok, so I run:

hp mplayer_x86

But after a while it claims

Applying: Haiku supporting code from Sergei Reznikov
Fetching package for devel:libcaca_x86 ...
*** Failed to find a match for "devel:libcaca_x86": Name not found
Error: unable to resolve required packages for build for mplayer_x86-1.3.0
Error:  dependency-infos:
Error:          /boot/home/haikuports/repository/mplayer_x86-1.3.0.DependencyInfo
Error:  repositories:
Error:          [u'/boot/home/haikuports/packages', '/boot/system/packages']

So I’ve tried:

hp libcaca_x86_devel

but, again, haikuports still claims about “Failed to find a match for <another dependency name>” and “Name not found Error: unable to resolve required packages for <the package which I attempt to build>”: in facts seems that I am unable to build anything, since I always get the same errors while attempt to build also other packages: as I’ve said I always get these errors also with any other packages which I attempt to build.

Can someone give me some hints? Seems very odd.
I miss something?

I think you can’t build the _devel package explicitly (?) so you should use libcaca_x86 (no _devel).
And yes, in the case of mplayer, lots of dependencies seems missing from the repositories, so it will be quite a lot of work to get them all up and running. You need a lot of patience, and probably some C and buildsystem knowledge for some of the recipes, which will need some fixes.

Thank you for the hint.
However, since the mplayer’s hpkg is present in the repo/HaikuDepot (but can’t install it due the issue 1263 on GitHub), I thought that his recipe was ok and could be just a matter of rebuild just the package.
However I encountered this error also for other recipes: I will look further.

Many thanks.

Yes, I am wondering myself how this package was built, because I need the recipe working for the release branch of Haiku. Maybe it was built from an older version of the recipe where there were less dependencies?