Basic audio editing / Haiku media encoding issues?

I’m going spare trying to find a decent basic audio editing tool for Haiku that works.

What I need is really basic -

  1. Ability to load audio file (mp3 and other standard formats) and view waveform (ability to zoom a desirable bonus)
  2. Ability to trim / crop audio from source file
  3. Ability to save file as mp3 (Bonus - other formats that Haiku handles, eg ogg, wav)
  4. Bonus: ability to fade audio in and out
  5. Bonus: other adjustments

I’m not sure if the software I have tried is out of date, just crappy (unlikely for some, given the amount of time it has been around) or there is a bug in post R1B3 with something to do with Haiku’s media encoding system, but everything I have tried has issues (maybe someone with these tools installed could try and let me know if they are having issues too???)

  1. KWave is feature-rich & ideal, but throws an error on save / save as (also corrupts original file if “save” selected; apparently it uses ‘lame’ for encoding mp3s; this tests out as “ok” when I check the settings)
  2. BeAE is ok, if a little flaky on editing, but throws a “can’t overwite file” both on ‘save’ and ‘save as’. If you change the file name, it writes a 0 byte file then throws the error
  3. Clockwerk is really for video and lacks the features I want. It also has severe audio playback issues (tho I’m not sure if this is a new problem). It throws a “general system fault” after creating a 0 byte file when I try to export an MP3 as well, and it appers to use the Haiku media/codec system like BeAE.
  4. Medo is new and under development, but came the closest to working. It is video centric, but gets the job done, as it displays waveforms and allows clip splitting and deletion. It uses ffmpeg instead of Haiku media codecs and successfully outputs a file (the only problem is it appears to introduce noise to the output file, which I have not yet been aboe to resolve with different encodings, bitrates and other adjustments).

NB - I am using Open Sound for my audio drivers, as the built in HDA drivers do not work on this AMD-based machine. Presently on hrev55271.

If others experience the same issues, I will log a bug with dev.

Thanks in advance to anyone who can help / confirm similar issues / etc :slight_smile:

update to beta3, AMD audio was fixed so e time ago

1 Like

I’m on the master/current repo. Just updated again, - still doing it on hrev55273, but at least it lets me dump a report from BeAE now.

which motherboard and chipset ? check the tickets for amd audio, your chipset might need to be added for the addressing issues

1 Like

1 Like

Check the Medo/Settings/Export tab, to enable BMediaKit export functionality (exposes bugs in BMedia kit convertors so use at own risk).

Regarding sound popping, this is an issue with the ffmpeg AAC encoding codec with some files (not all). If you switch to another codec, eg. AC3 you’ll notice that the popping disappears. I get better results with AC3 for all files, however most times AAC works like a charm. I dont know where the popping comes from (it may be the resampler), however I do know that switching to another codec resolves the issue. I cannot debug ffmpeg at this point in time.

Also, have you tried the latest (Beta 4). I did fix an issue with the sound resampler cache, where it failed to reinitialise the resampler context when seeking.


The FFmpeg AAC encoder is just not very good it appears:

1 Like

Will research and add - this is a rather weird Phenom II based Compaq laptop from that brief period when such things were considered a good idea… :stuck_out_tongue_winking_eye:


Yep, using Beta 4. Really like where Medo seems to be heading - thanks for your efforts :slight_smile:

Will try playing with codecs per your advice.

1 Like

Just tried using bMediaKit - got the same failures I had with other apps, so will go back to the ffmpeg. Have now logged the bug at!/pkg/auralillusion/haikuports/4/0/-/-/1/x86_gcc2?bcguid=bc2-PIXS

Unfortunately 32 bit…

Audacity would be great, but I cannot get it to build. Oh well - I shall wait for BMediaKit to be fixed.

Just a quick check - is anyone else having trouble writing/encoding media files via BMediaKit enabled media apps, or is it just something odd with my setup/config? Would be interested to know if I am suffering in isolation here, as it will help me decide if and how to adress this issue.

Sorry, Ive never tried. From your bug report it definitely seems like a Haiku problem and not on the application side.
Noticed one the reports mentioned “state: Exception (Divide error)”.

1 Like

With Medo, I have 2 encoding code paths: BMediaKit and ffmpeg. The BMediaKit path deadlocks/times out due to issues in ffmpeg add-on, which occasionally returns an error but can be resolved with a retry attempt, however the add-on most likely doesn’t cater for this then bombs out. The Medo ffmpeg path actually caters for encode chunk errors and retries the write in order to progress, which is why it eventually finishes. The same code I did in Medo ffmpeg encoder needs to be added to the BMediaKit add-on.

I decided not to attempt to fix the add-on since I wanted to gain access to more experimental ffmpeg settings/functions which I couldn’t access with BMediaKit API in its current state (maybe in BMediaKit v2). When I get time, I might see about fixing the add-on (really busy in real life at the moment).


Well, if you have the time to, we would certainly appreciate fixes to the add-on anyway. And, is the BMediaFile API so inflexible that we cannot add whatever FFmpeg options there are to it?


\o/ - any fixes that anyone can do would trigger cheers and cartwheels of joy from this corner :wink:

1 Like

Yes, I should :slight_smile: :astonished: Real life is overwhelming me with projects at this point in time, maybe during the christmas break :slight_smile: