Auto start a program at boot

I am using Launchbox and would like it to start automaticly. How can I do that?

As kim’s image shows, right click the app and create a link at /boot(Haiku)/home/config/settings/boot/launch

Ok, I appreciate the help. Here is where I am having a problem following it.

I have tried right clicking on the running program on the desktop. No option to create a link.

I have tried right clicking on LaunchBox in the menu and no menu pops up. So, just where do I have to be in order to get the option to create a link? It isn’t anywhere that I can find.

Ok, I opened the Desktop applets menu into its own window. From here I can right click on LaunchBox and get the “Create Link” option. But, no matter how hard I try I can’t create a LaunchBox link anywhere. I can’t create a link with any program in this menu, anywhere.

I can create links from other files and folders in my home menu, so I do know how to create links. I have been doing that since the first time I used BeOS 4.5 way back in the stone ages.

So, in summary. I have found how to get the right menu options on the LaunchBox program. But I can’t create a link. I tried creating one in the /boot/launch. I tired to create one in just /home, I also tried to create one on /desktop. Nothing.

I then, just for testing, created a link from one of my folders in /home, to all those places successfully.

I can create links into /boot/launch. Just not with any programs in the Menu.

OK, this is the easy way.

Open two folders in Tracker and place them so that both can be accessed:




Find launchBox in the first folder. Right click and drag it to the second folder and select Create link here when the mouse button is released…

Let me give you a bit of info. I am using a laptop with a trackpad. Not sure if this makes a difference or not.

So, I attempted to do as asked.

I opened both windows. When I right click on LaunchBox and drag to the launch window I get the “create link here” popup. I click “create link here” and I get… nothing.

YEA!! I figured out what I was doing wrong.

I was getting to the folder for LaunchBox by going to Deskbar Desktop App and clicking that. the opens up that menu list in a windows all its down. This does not work.

You have to go though the long way form haiku/…

If I may suggest. If a user is in a location where the file “right popup menu” options are not going to work. Please don’t display them.

You can’t copy it ether so it’s probably a security setting = you don’t have the rights to do anyting with the file/link.

It’s probably that with all packages :slight_smile:

That is probably correct at least when you come at it that particular way. However, the system gave me no indication that it would not work from there. It just simply didn’t work…

work fine

The DeskBar uses a special “overlaid” folder system to merge applications from different sources in a single menu. You can tell them apart from regular folders because they have a blue icon (instead of orange) and the Tracker window has a grey background.

From this virtual folder it is currently not possible to create a link (and various other things are broken). We have this on the TODO list for the Beta1 release.

From the virtual folder, you can relatively easily get to the actual one, in two different ways. The first one is to press command+up twice to get to the "deskbar" folder. There is a "menu" folder with the actual links, and "menu_entries" which is the blue-folder virtual one. From inside "menu" you can create links as usual.

You can also click on the "n elements" status bar in the Applications window. This is a popup menu allowing you to navigate to parent folders, and from there to the actual menu links.

1 Like

Thank you for the information, it makes much more sense now. Also, glad to hear that there is a resolution in the works for Beta 1.