Attribute not in index?


#1

So, one thing that’s been slowing down my screenshot review is that I’m writing an accompanying article on the advantages of BeOS. And I’ve been using Haiku alongside my Mac and Gnu/Linux for years now, so I’m no one new to it, and haven’t had this problem before… but I created a contact in People and the attributes inside (address, nickname, etc.) aren’t recognized in the search results from the Find box.

But in Tracker, they all appear.
But in Terminal (lsindex and listattr /boot/home/people/Example) they appear.

What the heck am I missing? I’ve left the system open for hours, restarted it, hit Identify on the file, and yet despite all I see, Find cannot find anything inside it. Do I need to run mkindex here or what am I missing? In the past, I haven’t had to do this, afaik, but I guess I am asking the experts what BeFS feature I’m not utilizing here. I’ve filed this under Be, as it’s a BeOS question. Could test this same ‘person’ on Haiku and see if it does the same thing.


#2

Also wanted to add that I ran chkbfs. No errors detected.


#3

Do you have select Application/Person in the menufield in the Find Panel?


#4


#5

Is that file resides on attribute enabled FS?
Is this FS indexes that attribute?

Pls, study the articles/guides about attribute handling.


#6

The index for those attributes has to exist before the file with those attributes is created. Does lsindex list e.g. META:name or META:wphone etc?

If it does, try duplicating your people folder and delete the original. That should add the new files to the index.

Not sure “reindex” existed on BeOS. You could try transplanting that command from Haiku (32bit) and see if it works under BeOS.


#7

Thanks @extrowerk, @humdinger, and @janus2 for your responses/help.

  • janus2: I couldn’t find where to select Person; I see it now – it’s the “All files and folders” drop-down. My bad.
  • humdinger: Yes, lsindex lists the META attributes. I can definitely try replacing the people folder and trying again. You’re right, I don’t see reindex on BeOS, either. Just mkindex.
  • extrowerk: yes, the file is on said disk, attributes are enabled, and the attributes in question, afaik, are in the index.

#8

Everyone, dilemma solved! @humdinger had the solution! I duplicated the people folder, removed the old one, made ‘people copy’ the ‘people’ folder, and restarted the computer. Started Find again, and eureka, it found the missing example file/attributes! For whatever reason, I guess there was a glitch in the FS. Never seen this before.


#9

Or the people files were created before the index. Reboot should’ve been uneccessary.