Atomic Pi / SD Card

So, using haiku-r1beta3-x86_64-anyboot.iso I’ve gotten Haiku to boot on an Atomic Pi from a USB.

I also imaged that boot iso to an SD card; booting from USB with the SD card installed in the Atomic Pi, I created a Be File System in the ‘Empty Space’ and formatted it.

I then installed Haiku on the large SD partition, and in some unclear order rebooted the system and removed the USB. Indeed, it booted from the SD card and I was using Haiku, even updating the default software.

But, on reboot, I get an InitialDeviceScan() returned error: No such file or directory and the debug prompt.

I tried duplicating my install, back to remaking the SD card, but I only get this error - I can’t duplicate the situation that allowed it to boot from the SD card successfully.

But it did… so this should be a problem that can be fixed… Any ideas?


Well! I hit the “reset” button on the Atomic Pi; configured it to boot only from the SD in the bios menu (disabling everything else) and suddenly it started booting again.

and, updating the (stock) software broke it again. Not sure what the offending change was, but maybe someone else does?

It’s hard to debug without logs, screenshots, etc. Updating the software broke it how?

Sorry. I appreciate your comment; this is my first day playing with Haiku and I don’t know where the salient logs are located. I don’t seem to have a Screenshot app installed so I’ll use a camera.

Updating the software (via HaikuDepot->Update Software, which offered me 66 packages) lead to this error:


I’m blaming the update because I had rebooted a couple of times successfully before I ran HaikuDepot and thought I was good to go.

For the second installation I had:

flash the iso onto a SD card. Boot from USB stick with SD card installed.

(I had a second image here, but am only able to include one.)

unmount /Haiku1; delete that partition (the installer on the SD card)
create a Be file system in the 29GB empty space; make it active; format it

Run the Installer; install to the 29GB partition

Remove USB, configure BIOS to only boot from SD.

After it broke, I followed the above procedure again but now I get the Haiku bootloader - which tells me it can’t find the Haiku boot partition. (The panic at the top of the very first image also claimed to be unable to find boot partitions.) So, whatever I’m doing differently is pretty subtle. I don’t know enough about the UEFI boot process to have. clue what is going on. Maybe the order in which I delete the small partition and create the larger one made a difference (in the way the boot partition was identified?). I have no idea.


1 Like

It might be worth trying a recent nightly image, as it includes lots of improvements from the past few months. I’d also add that make sure you have an EFI partition, but that must be done already since it’s able to get to the kernel. I’ve never used the Atomic Pi, so I don’t have any experience with it, but seems like a cool little device.

Wow - good call. I grabbed haiku-master-hrev55635-x86_64-anyboot and did the above. The only other difference is that I reformatted the small installation partition on the SD drive rather than deleting it but now it reliably restarts and powers off/on. Update only offered 13 packages; I went for it. And afterwards, it again came back up after reboot - so… I’m declaring the Atomic Pi @$40 a steal as a Haiku box. I’ll back up the sd card, install some more software, and get to playing.


Nice, I’m glad that worked out! Maybe some logs could be helpful to understand what changed between beta3 and hrev55635. It would be cool to use the Atomic Pi as a basis for HaikuBox.

So how do you like Haiku?

So far, so good. The Atomic Pi is really cost effective - not sure, given the browser, I can make a go of using this daily, but maybe I can cheat and use an X server… going to look for one.

There’s more to computing than a browser.

Yes. But my work requires me to use a number of browser based apps; so if I’m going to really use this OS, I need to use a browser.

1 Like