Atom D525 detected as 32 bit


#1

Hi all,

Not sure if this is me doing something stupid or just a bug.

I’ve installed Linux Mint on an old Atom D525 based machine. Trying to install the latest nightly in virtualbox and it’s puking, saying that it is designed for a 64 bit machine.

Checking Intel’s Ark site says this processor is 64 bit. Any ideas?

Here’s my host system info:-

adam@autumn-leaves:~/Documents/git/Paladin/Paladin/locales$ uname -a
Linux autumn-leaves 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:16:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
adam@autumn-leaves:~/Documents/git/Paladin/Paladin/locales$ cat /etc/os-release 
NAME="Linux Mint"
VERSION="19.1 (Tessa)"
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME="Linux Mint 19.1"
VERSION_ID="19.1"
HOME_URL="https://www.linuxmint.com/"
SUPPORT_URL="https://forums.ubuntu.com/"
BUG_REPORT_URL="http://linuxmint-troubleshooting-guide.readthedocs.io/en/latest/"
PRIVACY_POLICY_URL="https://www.linuxmint.com/"
VERSION_CODENAME=tessa
UBUNTU_CODENAME=bionic
adam@autumn-leaves:~/Documents/git/Paladin/Paladin/locales$ objdump -f /usr/lib/virtualbox/VirtualBox

/usr/lib/virtualbox/VirtualBox:     file format elf64-x86-64
architecture: i386:x86-64, flags 0x00000150:
HAS_SYMS, DYNAMIC, D_PAGED
start address 0x00000000000028f0

adam@autumn-leaves:~/Documents/git/Paladin/Paladin/locales$ cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 28
model name	: Intel(R) Atom(TM) CPU D525   @ 1.80GHz
stepping	: 10
microcode	: 0x107
cpu MHz		: 1799.913
cache size	: 512 KB
physical id	: 0
siblings	: 4
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl cpuid aperfmperf pni dtes64 monitor ds_cpl tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm dtherm
bugs		:
bogomips	: 3599.79
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

Thanks in advance.


#2

Could it be that your machine comes with a 32bit UEFI? If so, you have to set it to legacy mode and boot through the old fashioned BIOS, because we don’t handle 32bit UEFI (but know how to switch a machine to 64bit forem BIOS).


#3

No, no EFI support at all. It’s an old ASUS motherboard. I upgraded the BIOS last night to the 19 Oct 2012 version:-

https://www.asus.com/us/Motherboards/AT5IONTI/HelpDesk_BIOS/

I’m thinking it could be a weird VirtualBox setting, but can’t for the life of me find it.


#4

It doesn’t have virtualization extensions so will be slow anyway…


#5

Oh, I did not notice that you were trying to run haiku inside virtualbox.
Indeed, without Hyper-V hardware virtualization from the CPU, virtualbox will not only be slow, but also only emulate a 32bit CPU (since it can’t use the real CPU through virtualization anyway).


#6

Aaaaaah that’ll explain it then. I guess I’ll just use this machine as a general server for the house instead.

I have the beefy laptop I bought last year working with Manjaro Linux on it for anything serious. Just trying to build bootstrap for arm on it now following the instructions that were posted on the other thread.

Thanks all.


#7

Two things I can think of are did you select a 64 bit system option, like Other (64-bit) for Haiku? If it’s not a 64-bit option, VirtualBox won’t load a x64 box. Another is I see you’re using an Intel processor with a BIOS; do you have VT-x enabled in there? Without it, VirtualBox will still start and run okay, but not at its full potential. Also, is the board set to the right setting in System (not PIIX3 for example?)

Another option outside VirtualBox if it’s not seeing your x64 CPU at all is to use qemu with kvm, like qemu-system-x86_64 --enable-kvm -m 1G -hda name-of-haiku-hd.img

Hope this helps :slight_smile:


#8

You should read the thread before commenting … the D525 doesn’t have virtualization extensions at all whatsoever. So virtualbox won’t do 64bit… only slow 32bit, the performance of QEMU would probably me limited by this also.