Atheros AR9285 works randomly

I’ve installed Haiku on my old laptop with a Qualcomm Atheros AR9285 Wireless Network Adapter. The wifi card works on the first boot from the USB stick (not every time, but often) but after the first connection it doesn’t seem to work anymore. I can’t even see the wireless network anymore. I’ve tried two installations from scratch but I got the same behavior. I’ve read about an “ipconfig -ht” trick but I can’t understand what does it means.


-ht disables the high throughput feature.

Thanks, but what should I do? How to use that command?

I’ve tried
ifconfig -ht
ifconfig -ht WIRELESS_CARD

but they return errors

ifconfig /dev/net/iprowifi2200/0 -ht

You have to adjust the device path of course.

1 Like

This specific trick only works for the intel wifi driver anyways, and is not needed even there anymore as the driver was updated and the bug fixed.

The other drivers do not handle this and will return an error.

What this did was disable support for 802.11n, a newer Wifi standard which wasn’t reliably working with that driver at the time.


Thank you for your note. So this can’t be used in my case. Any other idea? :frowning: I thought Haiku was a really buggy OS but I’ve tried it yesterday and it’s really smooth and stable so I would like to try it a while. Thanks!

I’d nothing to lose so I’ve tried the -ht trick and… it seems to work. I’ve tried to reboot twice and I can see and connect to the Wifi networks. It doesn’t auto-connect on boot, but at least I can connect the network manually.

-ht also has a side effect of reinitializing a lot of stuff on the device, I think, so it may just be that this “fixed” your problem as a side effect.

The auto-connect on boot is some kind of general brokenness inside wpa_supplicant. I’ll try to look at that again once we upgrade it for beta2, after the ABI breakage has been resolved.