Asus EEEPC 900 - HAIKU don't start

Im trying to boot HAIKU on EEEPC900 from USB stick.
I doesn’t start…
it stops next image from network card image…

Is there any way to get some error / debug messages during boot prosess… help ?
Any ideas what is the issue…

I have tested USB stick on another PC and it did work…

If you press and hold down the spacebar quick before even seeing the Haiku boot screen, then you’ll be offered a choice of several start options to try including verbose boot output. I usually install ‘bootman’ on usb sticks so it will first stop (since I’m slow) and a simple return-space will then bring up those options immediately. But once you’ve seen the haiku bootscreen logo then it’s too late to choose options. It’s quick.

It seems HAIKU r1alpha3 has compatibility problems with Eee PC 900 (Celeron based). I have tried all imaginable combinations to boot Haiku but failed. I have tried installing haiku-anyboot to USB stick and to a SDHC card respactivey an boot from them. Then I burn the ISO to a CD and boot from external USB CD/DVD player attached to Eee PC 900. No success. Then boot on another PC from the ISO burned CD and install Haiku to a USB stick (full installation) and try this installation on the Eee PC 900. They all failed to boot on the same position, on the 4th icon (the memory(?) chip).
Haiku runs fine on a conventional PC in virtualization mode (QEMU) using the anyboot image and with VirtualBox using the vmdk image.
So, has anybody managed to install Haiku on a USB stick or SDHC memory and boot succesfully on a Eee PC 900 (Celeron based)? Could you please post the step.

OK, Problem solved! All that was needed was a BIOS update. I downloaded the latest Eee PC 900 BIOS file from ASUS and updated the netbook’s BIOS. Then I inserted the USB stick with HAIKU on it and boot. Voila! it all went smoothly. So, that’s the remedy to HAIKU’s boot hanging on the 4th icon during boot on a Eee PC 900.
Now I am trying to make Wi-Fi work. If I find a way to make Wi-Fi work, I will have an alternative OS (other than Linux, which I usually use -Macbuntu) for the netbook.

Great to hear! Could you add a comment to , possibly with a link to the newer BIOS?