Asus Eee PC 1001-PQD

Hi there,

I recently updated my Eee PC that ran a 64bit nightly beta3 from june 2021 to this week’s 64bit nightly beta4.
This netbook sports the intel GMA 3150 chipset supporting a native display resolution of 1024x600.
Although beta3 booted fine and showed intel GMA in screen prefs, beta4 only showed a black screen after the rocket.
Booting in fail safe graphics mode gets me to the desktop albeit with a resolution of 800x600 and horizontally stretched elements on screen :frowning:
I tried hard-blacklisting beta4’s intel_extreme.accelerant and intel_extreme exec files with a packages text file and copying beta3’s intel_extreme files onto the non-packaged corresponding folders. No way.
All I get is Vesa mode 800x600.
Is there anything I can do to enable this intel graphics native 1024x600 resolution?

Other than this and a broken wifi card, it’s just amazing!! to run Haiku on this low-end netbook (dual-core 1.67mhz Atom processor and 2GB of ram). It’s snappier than anything it ran before and really useful with gnome web. Looking forward to the beta4 release and beyond.

Please open a ticket and attach a syslog from the working beta3 build, and the non-working beta4 build. (Try to capture the syslog after a failed boot, i.e., let the boot hang on the rocket, then reboot with failsafe graphics and copy both syslog and syslog.old.)

Ok, I’ll do so later when I get home. Thanks


For what it’s worth, I also have an Atom N450 based netbook with GMA3150 graphics, and the integrated panel works just fine with the intel_extreme driver at 1024x600. No working brightness control, and using the VGA output works, but borks the image from the netbook screeen. Other than that… its only missing video overlay support :smiley:

I’ve seen black screens / failure to boot up severl times on that machine, with some hrevs being more stable, others almost unusable. Disabling SMP makes it work OK almost always (just disables Hyperthreading on these CPUs, as they only have one physical core).

Maybe you’re seeing a similar issue and not exactly a problem with the video driver?

Just my 2 cents.

Good luck!

Hi BiPolar…
I tried your suggestion but it doesn’t work either. Thank you anyway.

I’ve opened ticket #18158 just now for this issue.


Reading the R1/B4 release notes draft I found the following line: “Experimental support for VESA BIOS patching to enable custom video modes (disabled by default)”

Then I searched for tickets about this vesa bios patching code and found that a patch for intel chipsets was merged in march.

I know you are very busy but how can I enable and use this vesa bios patching to test it on my eee pc?
The syslogs I attached earlier have a line with additional vesa mode 1024x900 which is the native resolution for my netbook. So Haiku sees support for this resolution, it seems, but can’t use it somehow.

Hey, the commit mentions how to enable it:

Hey, thank you!
However I can’t find the vesa settings file on my system. Can you guide me?

You can find it in home/config/settings/kernel/drivers/vesa

Note that:

  • This wont work if you use EFI and not BIOS (then VESA patching is not possible)
  • This will apparently only work on some Intel cards with the current patches, maybe some very old Radeon or NVidia cards but not modern ones
  • Even on Intel, it doesn’t work on all cards.

Let us know what happens for your machine!

Thank you.
I found it. Set bios_patching true as mentioned.
After rebooting, screen app shows a list of other resolution including the native 1024x600 one. Switching to it though results in a even more stretched screen than 800x600 and the leaf menu is mirrored on the left of the screen as though it turned around.
Also Syslog says at the end:
KERN: vesa: patched custom mode in 2 locations
KERN: vesa: video mode patching failed!