Apps that i use on Haiku (OpenJDK)

This post is an “Updated version” of:

Thanks to OpenJDK i am able to run a lot of useful software!
Ok is not native, but i consider the fact that now, on Haiku i can do a lot of things… And new users that read this thread can say: “Hey! i can use Haiku for doing this!”

Java software on Haiku:

Is an image manipulation software:

A multi-platform editor for electronics

An mobile phones emulator (here i’m using a jar app for sending SMS)

Jukebox/music manager (I’m waiting PCM support by Hamish!)

To-do manager, notepad, image editor, feed reader and much more

Web Anonymizer

Port Scanner
Port Scanner

Glips Graffiti:
SVG image editor
SVG Editor

Diary manager and a tool for scheduling personal projects

Flickr Edit:
Edit, upload or backup your Flickr photos
Flickr Manager

Photo Scale:
Resize a batch of photo and optionally changes the format
<a href=‘ target=’_blank’>

Picasaweb Client:
Manages your albums and photos on Google Picasa

<a href=‘ target=’_blank’>

An photo album/image gallery creator
<a href=‘ target=’_blank’>


This is a very cool software!
Here a very quick result:

And as i’ve said in another thread i’m also running Thinkfree office!

So what are the steps needed to get these programs running?

First af all you need OpenJDK from Hamish, you can find the link to current release here: and extract the archive in /boot/apps
Then go on and you can find these and much more java applications.
2: put the jar file in a folder. For example: /boot/apps/myjarfolder
3: link the “jre” folder located in /boot/apps/j2sdk-image inside /boot/apps/myjarfolder
So the jar file will be present in /boot/apps/myjarfolder/myjarfile.jar
4: made a script like this:


export JAVA_HOME=/boot/apps/myjarfolder/jre
export PATH=$PATH:/boot/apps/myjarfolder/jre/bin
export LIBRARY_PATH=/boot/apps/myjarfolder/jre/lib/i386/:$LIBRARY_PATH

cd /boot/apps/myjarfolder

java -jar myjarfile.jar

make the script executable and enjoy!

Edit: Jajuk on sourceforge is outdated. You can get the last release on
Once you have download Jaujuk, you need to exec using “java -jar” command, the installer jar file.

Shouldn’t it be possible to set up haiku so that all jar files are associated with running java -jar ?

I’m pretty sure I’ve seen this done before…

I don’t know… But you can set
export JAVA_HOME=/boot/apps/j2sdk-image/jre
export PATH=$PATH:/boot/apps/j2sdk-image/jre/bin
export LIBRARY_PATH=/boot/apps/j2sdk-image/jre/lib/i386/:$LIBRARY_PATH

inside UserSetupEnvironment to be quicker in writing of script…

[quote=cb88]Shouldn’t it be possible to set up haiku so that all jar files are associated with running java -jar ?

I’m pretty sure I’ve seen this done before…[/quote]

But in any way, sometimes jar files needs:

java -cp jarfile1.jar:jarfile2.jar

and sometimes the -Xms=ram and others memory arguments.

But there is also a good native software, not only Java!
I’d like to show that with Haiku you can manage at the best your computer!
For example here I show a way to restrict the access on Haiku:

Lock Haiku>

And if you insert a wrong name:

Lock Intruder

This is: and is fully customizable: I made this graphics using the wonderful WonderBrush! :smiley:

I’ve tried JDownloader differently from your system I had to create a link of the Jdownloader.jar in the JDownloader directory, it uses a lot of jar library with hardcoded paths.

It installs, does an upgrade too and a little slowly it appears the GUI!

Sadly it doesn’t download anything, it says there aren’t link in any page, but the same links on Windows works so it’s not true.

I’ve see it uses JBrowser to download, in Windows uses the system default browser instead (Firefox in my case), I suppose this is the problem…

So I’ve tried to configure it to use WebPositive, but it try to open it and then it closes (core?) so nothing to do.

Using BeZillaBrowser gives me the same results: no link founds.

In Bterminal I can see a lot of excpetion referring to closed sockets…

You could try to using retriever ( works much better and is fully automatic: when you copy a link from you browser, retriever automatically ask where to save this file, and you can also configure retriever by file extension. For example i have configure retriever to automatically save jpeg files inside “Image” folder, zip files inside “Downloads” folder and so on for every file extension.


Correct me if I’m wrong but it seems a sort of “Download Accelerator”, JDownloader permits to download from youtube, rapidshare, putlocker, uploading and from some streaming sites…

It has automatically captcha recognition, autoresume, automatically extraction of compressed archives (with password, too)…

See here:

WeirdX - X Window System server in pure Java (OpenJDK) on Haiku:

Weird X

Not sure if it’s just me, but you only seem to be able to run one Java app at a time. I was able to get muCommander running but then when I tried to open Jomic, it wouldn’t load until I shutdown muCommander.

Is that normal ?


I am able to run more then one java app at time.
Have you followed my instructions? You have to link (not copy or move) the “jre” folder located in /boot/apps/j2sdk-image (for example) inside of every java app’s folder.
Let me know.

I was making bash scripts like this:-




export JAVA_HOME=/boot/j2sdk-image/jre
export PATH=$PATH:/boot/j2sdk-image/jre/bin
export LIBRARY_PATH=/boot/j2sdk-image/jre/lib/i386/:$LIBRARY_PATH

cd /boot/home/javaapps

java -jar mucommander.jar

and found I could only run one app at a time.

I then did as suggested and added the export lines into the UserSetupEnvironment and I can launch multiple apps at once. Trap for young players.

All right!

But in anyway you can consider to submit here your favourites java apps that you run on Haiku! For example muCommander is a nice app! :slight_smile:

Jomic - a viewer for comic book archives

Is there a good word processor in Java that we can try?

Sure: Thinkfree.
Haiku Office

Are there some instructions available for java and ThinkFree Office? Many thanks!