Anyboot live CD -> PANIC: I/O operation would need to be cut

CD: anyboot live CD (TDK brand CD-R) burned and verified with ImgBurn on Windows XP Pro SP3 machine [Dell Inspiron 6400]. md5 checksum of zip file was good.


HP Omnibook XE2-DB notebook
Pentium II 333MHz CPU (yeah, it’s a little slower than you recommend)
256MB RAM (max’ed out)
4.6GB Hard Drive
Teac 24X CD drive (read-only, no burn capability)
800x600 24 bit deep LCD display
Silicon Motion SM811 LynxE video card with 2MB graphics memory (don’t laugh!)

Hi Haiku people!

I wanted to check out Haiku on the 11 year old notebook described under “Hardware” above. I was hoping that, if I liked what I saw using the live CD, I could install Haiku R1 Alpha 2 on my hard drive.

Things started off OK; I got a nice-looking graphic screen (the boot screen?) with several little boxes. There’s one in the middle with what looks to me like a leaf in front of some kind of box. I think the leaf was blinking.

Then BOOM! I got thrown into the kernel debugger. Please don’t ask me to type everything on that screen! It starts off:

PANIC: I/O operation would need to be cut.
Welcome to Kernel Debugging Land…
Thread 12 “main2” running on CPU0
stack trace for thread 12 "main2"
kernel stack: 0x8216c000 to 0x82170000

Then there are 32 frames (0 to 31) listed and finally the “kdebug>” prompt.

I never used an anyboot image before but have done just fine with lots of ISO images. Oh, I changed the ISO and Joliet labels to something that made more sense to me; could that have caused my problem?

Anyway, should I try downloading and burning the ISO image?

I tried booting into safe mode but don’t know if I’m doing it right. Identical results. I held down the shift key while the CD was booting, then selected safe mode options. I used my space bar to put an ‘x’ in front of the Safe mode option, returned to the main menu and selected Continue booting. No joy. :frowning:

I’ve got Knoppix and Damn Small Linux live CDs that boot OK on this old notebook if I use cheatcodes like fb800x600 and vga=789.

Any help getting the live CD to finish booting so I can see what Haiku might look like on my ancient machine will be much appreciated.

Fairly sure I’m right too. I searched Haiku’s source and that error is only in the file I pointed out in the ticket.

For SATA CD/DVD drives, I have seen them treated like SCSI and maybe all ATAPI drives are treated like SCSI too?

Could be awhile before it gets fixed. It may only affect your CD-ROM drive so you can always get a haiku image (raw or anyboot) and dd to drive (or partition). dd’ing might work to get haiku onto that laptop. dd’ing to entire drive is the easiest but better to dd to 750 MB partition (requires boot loader) because you lose drive space. Once dd’ed to a partition, you can boot and run installer to install to another partition.

That driver was meant for Read(10). Your CD-ROM drive is saying it wants Read(6). Seems that Read(6) is not fully or properly supported causing the panic.

I do not believe scsi_periph affects the hard drive.

Best to include photos as attachments to ticket. (ie: attach file) This way photo sticks with the ticket no matter what.

PS if you look at dmesg in ticket it looks like CD-ROM & USB are only treated as SCSI devices. dd to hard-drive/partition would likely work.

Didn’t see the need to open a new ticket when there’s one open already addressing the problem (or not). I didn’t see a way to attach my pic when merely adding a comment to an existing ticket so I posted a link to my KDL pic on Flickr instead.

I don’t know how to dd the anyboot image on the LiveCD to the ancient notebook’s HD. I’m hardly a Linux wiz. As a matter of fact, I’m interested in Haiku as an alternative to putting some Linux distro on my really old notebook, even if Haiku’s only in Alpha.

I have a USB cabinet for 2.5" ATA/IDE HDs and a newer laptop. I guess the idea is to boot some flavor of Linux on the newer laptop with the USB cabinet plugged in and then open a console window to do whatever the dd command would do. The HD from the ancient notebook has a bootable primary Linux partition on it now with a Slackware Linux distro that I am sick and tired of trying to make work with my video card. I guess I could change the partition to a BeOS partition instead, dd the anyboot Haiku image to it, then try to figure out how to edit the GRUB loader to boot the Haiku image. All stuff for someone like me who’s not fond of the command-line world.

EDIT: If you can attach the old laptop drive to new laptop with external USB drive enclosure, you may be able to boot Haiku CD on new laptop and have it install to old laptop drive connected by USB. I have used the installer to install to usb drive (key). So, this should work and make things way easier.

for dd you need image in raw or anyboot format. You can do it from Linux, Windows, FreeBSD, MacOSX. Linux LiveCD may work. You still need access to the raw/anyboot image (from partition or usb drive).

dd to usb drive but similar method for hard drive:

dd sets the size of partition or drive to actual image size, ie: 750 MB, no matter how big drive/partition really is. If you dd to entire drive you don’t need boot manager; only if you dd to partition. Good to dd to entire drive first to test if Haiku boots (easiest way).

Better to dd Haiku to a 750 MB partition, boot Haiku from there, run installer, and install to another partition on the drive. Only issue is you need boot manager when you dd to partition. If you have Linux (partition1) (you can use Grub), you can dd Haiku to partition2 - boot - run installer and install Haiku to partition3. This way Haiku on partition3 will use up entire space available.

PS I never said to open new ticket, only to attach image to ticket. Adding to ticket was the right thing.

PPS Grub requires Linux partition. You can replace Grub once you boot Haiku by running bootman from terminal.

Anyboot image is neither ISO 9660 nor Joliet. Its a HDD image with a BFS file system so you can’t edit the label !
Just burn the image. ( But I don’t think that the label is the problem ).

  • What image did you use? Alpha2 or a nightly build ?
  • do-you know how your "Teac 24X CD drive" is connected ? Sometimes CD-drives use a PC-Card/express-card bus (currently unsupported) so the kernel is loaded, using BIOS calls and when the kernel starts,BIOS calls are not available anymore, the kernel tries to access the disk by itself and... BOOM!

PS : Did you try “use fail-safe video mode” ?

As I said in my original post, I wanted to try R1 Alpha 2. I did not use the nightly build.

The CD drive is on the ATA/IDE bus along with the HD. I’ve booted Knoppix and DSL liveCDs from it and frugal installed DSL onto the HD from the DSL liveCD.

I will try the “fail-safe video mode” as soon as I find out how to get there.

I was encouraged for the first few seconds when I saw what I think was the boot screen with the gray boxes below the Haiku logo.

Thanks for responding @starsseed.

You have to be quick on the draw but dont just lay on the spacebar as soon as you hit the power button either. During boot, you’ll see a series of dots appear in the upper left corner of the screen, when they finish (about 3 inches of screen space) it jumps to the Haiku logo and icon boxes. You have to hit spacebar during the time you first see those little dots. Yeah, big window of opportunity. WHen you get to the “options” page, select “safe mode” and see if that works. Oddly, just letting Haiku boot past the icons and if it dumps you to a black screen and you hear the CD drive spin down, yu can press Ctrl + Alt + Esc…or Ctrl + Alt + Backspace…cant remember ATM…and that will give you an option to choose “safe mode vesa”. Then it’ll proceed to the desktop.

Your issue relates to this ticket which I updated with additional information.

Hopefully a developer will look to fix it.

What you can try until this is fixed is:

  1. turn off DMA (safe mode options), if that does nothing then try dd’ing Haiku onto the drive, if that works, then create 750 MB partition and dd Haiku to it.

little precision about computer architecture:

An ATA/IDE controller is not directly connected to the processor.
There is a bus in between (I simplify a bit the north/south-bridge). Often, it’s a PCI bus, but on some laptop, it can be a express-card bus.

It’s got to be PCI.

Quoting my original post “I wanted to check out Haiku on the 11 year old notebook”. 2010 - 11 = 1999. The Personal Computer Memory Card International Association created the ExpressCard standard in 2003.

For my silicon living fossil:

  • North Bridge: 443DX
  • South Bridge: PIIX4e

I’ve been a little frustrated by bad OOBEs lately and may take off a day or two off from trying to get the liveCD to finish booting.


I think you’re right because the kernel debugger I get talks about “scsi_periph” and “scsi_cd”; just like the ticket you referenced mentions. (Oh man, you can’t type angle-brackets in this forum or everything after the first one disappears!)

I don’t know if it’d help, but I took a pic of my original kernel debug screen and have compressed it down to 320+K. I think it still is quite readable. Would someone like to look at it?

I booted off the Haiku liveCD on a 4 year old Dell Inspiron 6400 laptop and had no problems, so I think the CD is OK. I’d like to get Haiku to work on my 11 year old HP notebook, but I guess I’ll have to wait until this problem of booting from older ATAPI CD drives is fixed.

I used dd for Windows and put the Haiku image file in the same folder as dd.exe so I wouldn’t have to specify a source (if=) path. The only weirdness in my ignorant opinion was that dd for Windows didn’t see the old notebook in a USB cabinet as a removable device; just another HD.

I practically pooped a purple patty when the boot process finished and Haiku was running. Of course it came up in the default 1024x768 resolution on my 800x600 LCD. For whatever reason, I can’t change the resolution from Haiku’s settings (not implemented yet?), so I have to set the fail-safe resolution to 800x600 and then select use fail-safe video mode.

It took a while for me to see that the background had to be set to “center” for me to get the whole background to show. I thought that, even though I had the tracker in the upper right corner, I still had resolution problems. I was amazed that two finger scrolling worked on that 11 year old touchpad.

I can’t make a lot of stuff work; I’m going to have to spend considerable time reading the documentation. There seems to be no binding between data files and what application is used to open them.

I guess what’s next is boot DSL from my USB flash pen drive using a floppy and make a 750MB partition. I’ll have to figure out how to get GRUB onto the notebook HD. Then I’ll dd the Haiku image to the 750MB partition and install Haiku to a much bigger partition from that 750MB partition. It’ll probably take me a long time to figure out how to tell GRUB to boot Haiku the first time from the 750MB partition I dd’d to. Finally, I’ll remove the DSL partitions and the 750MB partition and try to resize the Haiku partition to take up the slack.

With 256MB of RAM I suppose I’ll need a swap partition for decent Haiku performance. I guess the Haiku installer will take care of that. Wish me luck.

There are other boot managers out there that don’t require Linux. Search for them. Smartboot may work (try this or look for another first):

Your video card might be using a native graphics driver. Type listdev in terminal, provide output for graphics card only (3 or 4 lines worth). fail-safe video mode = VESA graphics.

Grub installs with Linux at very end (last step). If you go with Grub, install it to MBR. Then when you boot Haiku, run bootman to replace Grub. Search these forums for info on adding Haiku to Grub. Instructions are different for Grub1 & Grub2. Try to find out which version of Grub you have. Run bootman again off your final Haiku install to be safe.

You can’t resize bfs partition (Haiku). So, you’ll have at least two partitions when done.

Use Gparted LiveCD to partition and resize which works with Linux & Window file systems.

It is FAIRLY difficult to install Haiku when install CD does not work or you cannot boot from USB to install. Good to hear you figured it out.

Well I put this project on the back burner because I didn’t understand very much of the last response.

I used the GParted live CD to create a partition of around 4GB in the remaining unallocated space on my 4.6GB HD. I booted into the directly installed CD image (about 650MB) and ran the Haiku installer to install Haiku into the 4GB partition.

Following the installation guide on the web site, I also installed boot manager on the HD and rebooted. I now have the CD image and an installed version of Haiku and they are both accessible and bootable from boot manager.

It is more difficult to boot into failsafe-video mode with the installed (4GB) version because I have to be very quick to hit the shift key after I hit enter to start booting.

I don’t know the difference between a device driver and a native device driver. I also don’t know how to make listdev show only graphics card output. What listdev shows for my graphics card is:

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
vendor 126f: Silicon Motion, Inc.
device 0810: SM810 LynxE

which is basically correct. From suffering with previous attempts to put Linux on my working HP fossil, I know that the siliconmotion SM810 LynxE XOrg driver is right for my SM811 LynxE graphics card.

When I try to apply a setting in Screen Preferences, I get this message:

"The screen mode could not be set: General system error"

I don’t know if this is because I’m forced to boot using the VESA 800x600x24 failsafe-video setting in order to avoid booting into a 1024x768 screen where the tracker is off the screen in the upper right corner.

I guess I’m stuck with being forced to use fail-safe video and with not being able to use my CD drive. I tried to play a music CD but got the same “PANIC: I/O operation would need to be cut” error message as when I tried to boot off of the Haiku live CD. Judging by the age of the ticket we’ve talked about, I’ll never be able to use my CD drive in Haiku.

Haiku can see external USB drives, but I can’t play MP3s off an external USB HD, at least not if I mount it read-only.

Lots of reading to do to see if I can make Haiku halfway usable.

I’d like to delete the 650MB Haiku CD image and expand the installed partition to take up the whole 4.6GB using GParted, but I’ll wait until I see if I can get some other things working first. Examples are my ethernet adapter card in the PCMCIA slot and, fantasy of fantasies, the wireless card, also in the PCMCIA slot. Not to mention playing MP3s off an external HD.

Oh well. Guess I better start reading. At least I didn’t have to install GRUB.

There is an easier way to get the boot options menu: at the Bootman menu, hold the Shift key down and then hit the Enter key to boot from the desired partition. That should do it. More details here:

There is an easier way to get the boot options menu: at the Bootman menu, hold the Shift key down and then hit the Enter key to boot from the desired partition. That should do it. More details here:

  1. failsafe video mode can be set by creating text file called vesa.

Create vesa text file and place it under …/kernel/drivers

  1. You gave listdev for your graphics card like I wanted.

No native driver for that graphics card. Will have to use vesa video driver. OK still because many people use vesa on Haiku for newer graphics cards. ie: my laptop uses vesa driver.

That video card probably has 1 or 2 MB of video RAM. Maybe too little for 1024x768x32. Try 1024x768x16. A lower resolution or bit depth will use less video RAM.

  1. The PANIC issue relates to your CD drive like you figured out. You won’t be able to use CD drive until that ticket is fixed. Which is not happening for long time since it affects very few people with much older hardware.

  2. Haiku should play mp3s off usb drives. I will have to check this myself to see.

  3. Gparted does not know how to resize bfs (Haiku’s filesystem). You’re stuck with 2 partitions when doing a hard drive partition to partition install. Only way to get 1 partition is to install from CD, DVD, usb key or sd(hc) card, etc.

  4. Haiku does not support PCMCIA. No one has done the development work for it. Internet and anything else is not available through PCMCIA. Internet only supported with onboard ethernet chips and usb-to-wired network.

Haiku offers support for 2 or 3 usb-to-wired ethernet adapter chipsets (require usb port on laptop). That is the only way you can get networking on that laptop under Haiku. Otherwise no Internet.

EDIT: cleaned up my reply somewhat