Any status update on the ABI issue concerning the nightly builds?


#1

Curious if/when us Haiku users will get the green light for updating the OS to the latest nightlies? Is the ABI issue still in play?


#2

It looks like it is being ignored by the devs. They seem to be waiting for the ABI breaker to fix it. In the mean time we are stuck waiting to update and people new to haiku end up downloading a broken version with a non working web browser.


#3

the x86_64 images are OK for download and update: https://download.haiku-os.org/nightly-images/x86_64/


#4

the x86_64 images are OK for download and update: https://download.haiku-os.org/nightly-images/x86_64/3

That’s nice, but it won’t run on my 32 bit computers.


#5

So how did Haiku x86-64 avoid the ABI chaos?


#6

See http://cgit.haiku-os.org/haiku/log/build/jam/repositories/HaikuPorts/x86_64 for the history of the x86_64 repository.


#7

So there are devs willing to update the 64-bit version of Haiku, either fixing or avoiding the ABI issue, but not update the 32-bit version, likewise? I think that is a bit telling in some regard. Perhaps people realize the original goal of binary compatibility (R5 equivalence) is kinda pointless this many years down the road… too little, too late, perhaps? Dunno.

If compared, side-by-side, what does 32-bit Haiku offer that 64-bit Haiku does not/can’t? How many people, 17 yrs. down the road, even use whatever software only runs on BeOS R5 or Haiku 32-bit?

Just wondering…


#8

OpenJDK? It gives you some VNC client at least and muCommander is a killer app. Though I myself am trying to setup a Windows-less workflow with 64-bit version for daily use… Thanks to 3deyes, QupZilla now handles media streams, which really gives a decent web-browsing experience (Facebook, YouTube, whatever). QMPlay now handles videos perfectly without any flickering (motion blur filter turned on), which was an issue before. There is a full-blown Wireshark and now KDE apps on the line, but I am still lacking muCommander (maybe just can’t get myself accustomed to Tracker). So yes, there is still some software that can keep users on 32-bit version.


#9

There are some 32bit only apps left: GoBe, Wonderbrush, SynC Modular, APlayer, …

I still run 32bit most of the time because of this. However I am currently intvacation so no time for fixing things. I did update the webkit package, but I must have missed something: it works for me but other users are still complaining about it.

Also I’m currently testing the new auto-generated repo, which means I have less motivation for taking care of the current manually built one. This means it is unlikely that I will fix packages in that repo, but quite possible that I will work towards deprecating it and completing the migration to the new one.


#10

Hello PulkoMandy. About that, I think the problem is that the new webkit package, are build against a newer version of libpng16 that the available in the repo.


#11

Most of the broken packages are now fixed on 32bits too, thanks to Humdinger!


#12

Hello. I’m not sure, if this is the correct thread, to post my problem? It seems to me, that all apps (Qupzilla, Lazarus, qpdfview. LibreCAD etc…) , bild with the QT4 framework, does not work any longer? All starts up with the following error, which tells me something about missing symbols:

Maybe the QT4-4.8.7-6 package is also broken?

Thank you in advance.

Joerg


#13

I’m not sure this is related, but I’ll give it a try. I installed Haiku using a CD using an older nightly build (May 15, 2017, I not sure of the release number). When I tried updating using Software Update or the command line, it said there were no updates. I know that there have are. How can I fix the problem?


#14

Yes it is the ABI break…


#15

Go into Haiku Depot -> Tools -> Manage Repositories and then you need to enable the repositories that end in “current”


#16

Hello. Yes, the Qt libraries must be updated, too. I guess it will be donde soon.


#17

I just tried to build libqt4. Failed: http://sprunge.us/FghY
It’s not in the auto-buildbottled repo either, so I guess there’s a general problem.

I don’t know what’s the plan with Qt, maybe move straight to Qt5?
I’m not a big user of Qt (yet?).


#18

It looks like the binutils pkg is also broken.


#19

That fixed it. Thanks


#20

My gcc2 repo has 1405 packages ATM. my x86_64 repo has 663. When you consider that about 300 packages are “any architecture” packages shared between the two (fonts, documentation etc), that tells you the difference between what is available for the two.

This is not just because I am crap at recompiling. I am, but that’s not the point. There are hundreds of applications for which the source simply has been lost. Those apps will NEVER run on x86_64. Until we see a major push of new user app development, we need them. We need them to point to when a newbie asks “what can I DO with Haiku?”

I agree that x86_64 is the future. But it is not the present. Ideally, we’d have a 32-bit subsytem on x86_64 the way OS/2 used to contain an entire Windows 3 installation. But that would be a big job.