Alt key not working in emacs

I decided to ditch Spacemacs and use my own configuration. To save some seconds during startup. CCSL (LSP) no longer crashes, but it doesnt work either. So I enabled semantic-mode instead as suggested above. It’s not bad.

I thought that the “all-the-icons” wouldnt work in Haiku, but I decided to just download them, and then install them manually. /boot/home/config/non-packaged/data/fonts. After a restart (SPC q r in my config) it just worked.

I finally managed to compile vterm, but it doesnt load. So In the screenshot I am using ‘term’ instead.

I am using general.el to change my keybindings to be close to something that spacemacs offer.

Here is my configuration:

If you want to give it a try (backup your previous settings):
And copy init.el in .emacs.d folder in home catalogue. My configuration will take care of downloading all the packages needed.



I’m interested in why the libvterm module doesn’t load: does it crash, or does Emacs display an error message?

Either way, that could be a bug in the Emacs dynamic module support, which is supposed to work on every platform except for MS-DOS.


Hi @hgsfghs
Message buffer is empty. Exact same config on macOS launches the vterm. M-x 'vterm has the same result so there is probably nothing wrong with keybindings either.

Thanks, so are you saying the vterm buffer doesn’t show up after typing `M-x vterm RET’?

Exactly, it just splits the window and create the current buffer again.

Ah I think that’s because libvterm doesn’t know how to create ptys on Haiku.
I think this should be taken up with the libvterm developers. Haiku might already have a port, so you can also install that from HaikuPorts and configure emacs-libvterm to use the system libvterm instead.


FWIW, Vim’s libvterm works nicely on Haiku. It was glitchy at first, but was fixed upstream later on.

1 Like

Then I suggest to install that libvterm, and to tell emacs-libvterm to use it instead.

I don’t think it will work as-is. It is modified to work with Vim, so I don’t think it will ever compile. It might be a reference to check Vim Haiku code to see what was fixed though.

libvterm shouldn’t have to be modified to work with anything, which includes vim.

So I think it would be nice to give it a try, to at least verify that it’s not a bug with Emacs.

As far as I know, the API to open pseudo-ttys should be the same as on other POSIX systems. You may run into problem if you expect the devices to be in a specific location (/dev/pty* for example) as we have them in a subdirectory (/dev/pt/*), but that should be the only difference.

Let us know if you find something in Haiku behaving unexpectedly, there could be bugs too :slight_smile:

I cannot get my theme loaded in Haiku. Works on both my macOS machines (in all emacs versions 27-29). Dunno why.

I am using autothemer and the theme only works in 0xFFFFFF color space (Graphical mode)
Here is my config is there something obvious wrong with it?

Can you describe why it doesn’t load? Does an error occur?

If so, pass `–debug-init’ as a command line option when starting Emacs, and send the backtrace produced here. Thanks in advance.

1 Like

Emacs doesnt start for me at all anymore. It crashes when I try to debug it as well.
Uploaded *.reports file here.

Thanks, I’ll look into this.


It’s a bug with 16 pixel wide fringe bitmaps. I’ll fix it tomorrow, thanks.

In the meantime, you can start Emacs with fringes disabled, or remove the package which uses doublesized fringe bitmaps (they aren’t that common.)

1 Like

I think its Flycheck that uses fringe-bitmaps. No worries Ill check later this week.

It should be fixed now.


Big thanks, upstream or in HaikuDepot?

Upstream. I’m testing it now and thinking about updating the HaikuPorts recipe to the new git revision.