Alt key not working in emacs

Having classic *nix software on Haiku with its native sauce is just blessing.

1 Like

While emacs is an OS itself, it should respect or at least try to respect the host OS HIG. Maybe some people enjoy using ductape-work systems where every application thinks it will reform the world, but all of them works differently, assumes things differently, making excuses and exceptions everywhere. Sadly not just programs doing this, but peoples too, this is why some people (like me) dislike linux and everythig originated in unixen and keep as much distance from those programs and ideas as humanly possible.

Haiku supposed to be different.

Yes, i know. I did.
Let me add: i was young and i needed the money.

I better like the word “pragmatic”, consider to use this in the future, thank you.

I think most people will use their own init.el (or org-mode based). If they dont like the behaviour they will customize it. But I think most people would expect the same behavior as on other OSes.

1 Like

Thats a true point, have to say.


You may have put the first patch and recipe into the Haikuports repository, but emacs has been around for a very long time on Haiku. Here is a screenshot of me running emacs on Haiku from almost 10 years ago. I still probably have the IRC logs from 12+ years ago when I got it running with a long time user named DraX.

Yes, i recall i have seen your image and this gave the motivation to make the recipe.

I don’t find plausible that displaying scrollbars on the right is a defining feature of Haiku programs instead of using the Haiku API.

That port never did work right. For instance, `baud-rate’ was stuck on 0, which caused (for example) I-search to disable some display features in order to minimize your hypothetical modem bills. The pseudo-terminal feature was also broken.

Besides, limitations of using Emacs in the terminal caused this thread to be created in the first place.

emacs is emacs and it will always keep its own quirks. That is fine.

If you want native apps that perfectly integrate with Haiku, it will not come from ported applicaitons, no matter how much effort is put into it.

I think everyone has understood that emacs is not for you, I suggest that you don’t install it and stop complaining in this topic, as it just brings unneeded negativity.

You can’t both complain about people saying “I would use Haiku if it had X and Y”; and also say “I would use emacs if it had a scrollbar on the right instead of the left”, when we all know that in fact you are not interested in using emacs at all and will keep finding more reasons for that.

So, let emacs users be happy with this, and for yourself keep using native editors like Pe and Koder if that’s what you’re happy with. There is certainly room for both approaches here.


I decided to ditch Spacemacs and use my own configuration. To save some seconds during startup. CCSL (LSP) no longer crashes, but it doesnt work either. So I enabled semantic-mode instead as suggested above. It’s not bad.

I thought that the “all-the-icons” wouldnt work in Haiku, but I decided to just download them, and then install them manually. /boot/home/config/non-packaged/data/fonts. After a restart (SPC q r in my config) it just worked.

I finally managed to compile vterm, but it doesnt load. So In the screenshot I am using ‘term’ instead.

I am using general.el to change my keybindings to be close to something that spacemacs offer.

Here is my configuration:

If you want to give it a try (backup your previous settings):
And copy init.el in .emacs.d folder in home catalogue. My configuration will take care of downloading all the packages needed.



I’m interested in why the libvterm module doesn’t load: does it crash, or does Emacs display an error message?

Either way, that could be a bug in the Emacs dynamic module support, which is supposed to work on every platform except for MS-DOS.


Hi @hgsfghs
Message buffer is empty. Exact same config on macOS launches the vterm. M-x 'vterm has the same result so there is probably nothing wrong with keybindings either.

Thanks, so are you saying the vterm buffer doesn’t show up after typing `M-x vterm RET’?

Exactly, it just splits the window and create the current buffer again.

Ah I think that’s because libvterm doesn’t know how to create ptys on Haiku.
I think this should be taken up with the libvterm developers. Haiku might already have a port, so you can also install that from HaikuPorts and configure emacs-libvterm to use the system libvterm instead.


FWIW, Vim’s libvterm works nicely on Haiku. It was glitchy at first, but was fixed upstream later on.

1 Like

Then I suggest to install that libvterm, and to tell emacs-libvterm to use it instead.

I don’t think it will work as-is. It is modified to work with Vim, so I don’t think it will ever compile. It might be a reference to check Vim Haiku code to see what was fixed though.

libvterm shouldn’t have to be modified to work with anything, which includes vim.

So I think it would be nice to give it a try, to at least verify that it’s not a bug with Emacs.