Alpha4.1 on an iMac -- mouse is frozen

I have been using Haiku alpha1R2 on an iMac for 2 years. It has worked perfectly.
I installed 4.1 today from the iso CD. The CD boots (in safe mode), and the
installer runs perfectly. If I then try to boot from the hard disk (in safe mode),
it boots, but the mouse is frozen. I then tried checking all the safe mode options.
It makes no difference, the mouse does not work. Any ideas? If I boot into the
Haiku desktop from the CD, everything works perfectly, including the mouse.
But if I boot from the hard disk the mouse is frozen.

further info:
when booting with debugging on, it stops at the following point:

write access attempted on write protected area 0x477 at 0x100f0000
vm_page_fault: vm_soft_fault returned error “Permission denied” on fault at 0x10fcf7 ip 0x8012ad58, write 1, user 0, thread 0x32
error starting /bin/sh error=-1

I have been able to get alpha4.1 to boot on my iMac, but I don’t know if it is reliably repeatable.
In case anyone is trying to install 4.1 on an iMac, here is how I got it to boot.

  1. launch the installer CD, holding shift key. When the safe mode window
    comes up, choose “select safe mode options”. Of these choose the 1st (safe
    mode) and the 4th (fail safe video). Then continue booting, and install Haiku,

  2. reboot from the installer CD, same as before, but this time boot into the desktop.
    Mount the hard drive.

  3. the problem seems to be with virtual memory. Whenever it won’t boot from the hard drive,
    and I reboot from the CD, virtual memory is always maxed out, asking for a humungous swap file.
    Open the virtual memory preferences, and turn off “choose swap size automatically”. Move the slider to
    select a small swap file size.

  4. Open hard disk/system/boot/Bootscript using Pe. Comment out every line that says
    if (SafeMode != ‘yes’) then
    and comment out the matching fi.
    Do the same for hard disk/system/boot/SetupEnvironment.
    This is in case you need to reboot using safe mode.

  5. Reboot, this time from the hard disk. Hold shift key. When the safe mode window comes up,
    choose “select safe mode options”. Then only choose “fail safe video” out of the options. Continue booting.
    If it doesn’t boot, check the virtual memory prefs, and try again. Sometimes the second attempt will boot,
    even if the first one doesn’t. If it still doesn’t work, try again, this time choosing “safe mode” and "fail safe video"
    out of the list of options. I can’t get it to boot without choosing “fail safe video”, even tho Haiku understands the
    video card perfectly well.

  6. After getting it to work, I made the mistake of shutting down and powering off.
    The next day it wouldn’t reboot. Eventually I got it working again, using the above method.

A frozen mouse is a bug.

Please be a good open source citizen and file a bug report: and