Alpha2 problem with connecting to ad-hoc wireless network

Hi all.

I waited some months for this release, mainly because I wanted to be able to use my laptop with a wireless connection. I downloaded and installed the alpha2 a couple of hours ago, set up everything (including running the required script), but I can’t get wireless to work. The network in question is an ad-hoc wireless network with WEP protection (13 characters ASCII key). I tried setting the network to static mode instead of DHCP but it’s still the same. When I try to connect I pass the hex key preceded with ‘0x’ to the setwep command. When I cat the syslog I see the messages from the wireless driver regarding beacons of the networks in range (including my own network). What am I doing wrong? Is it actually possible to connect to ad-hoc networks? (just in case, my network card is Intel PRO 2200 BG)

P.S. One unrelated question. Is the ATI Radeon X700 card supported? When I boot I have to manually choose Safe Display Mode. If not, I get a black screen. This may actually be down to my machine (Asus A6Va) which had an identical problem in Ubuntu, and it turned out that the driver defaulted to use the external VGA output. The solution was to tell the driver explicitly to preffer the internal output by changing the xorg.conf. I can’t test that now, since I don’t have a monitor around, but is it possible to change that in Haiku? Or at least use the safe mode display adapter by default so I don’t have to enter safe mode options every time I boot?

Trying to get wifi to work here too w/o success. I have a wired port and wifi intel 3945.

Wondering if the wired network is the problem and that Haiku does not try the wifi at all if it failed using the “first” wired network.

Anyone know if there is a way to disable an interface ?