Alpha 4 - First Sail

I was surprised to see the Alpha 4 release on the home page today … a few days earlier than expected. So, of course my first impulse was to download the anyboot file, and “dd” it onto my USB drive.

I tried a number of mirrors (really slow) until I hooked into the one in Sweden. I guess Haiku is gaining popularity. There must be quite a few download requests hitting the servers this afternoon. I remember seeing the download totals on one of the developer’s pages for the Alpha 3 release. If I remember correctly, the total number of downloads was in the area of 170,000 (woot woot).

Anyway, my anticipation was put off a bit as the splash screen was followed by total black-out on my MSI netbook. For some reason, Alpha 4 didn’t like the netbook video (Intel Mobile 945GSE Express Integrated Graphics Controller). Just a couple minutes ago I rebooted with safe-graphics mode selected at 800x600@32 bits, and (except for needing the safe-mode) things seem to be working OK. I see the uptick in Webkit and WebPositive versions. Great!

I see this bug for the Intel-extreme/945 driver has already been given a ticket:

However; the ticket seems to have been closed about 8 months ago. It looks like the changed code implemented a “most but not all” scenario. The netbook (MSI u120 / Intel 945 graphics) worked great under Alpha 3 at a resolution of 1024x600.


I don’t think removing the video driver is the answer. You have roughly the same graphics as I. When I look in the syslog, I don’t see that any inappropriate drivers are being loaded. So, if we don’t want VESA (800x600), then we need a fix for the Intel_extreme driver. I have submitted a ticket:

  • Ron

I also downloaded A4 and installed it. I used the installer to install it over an existing haiku build.
My NC8000 has an ATI mobility 9600 graphics card. Haiku A4 started well but the backlight was off.
I could barely see what’s on the screen.
Starting in failsave mode solved the problem. I noticed in the syslog that the radeon driver was used (not the ati driver).
I removed the radeon driver and accelerant, rebooted et voila all works well now.

My Asus Eee PC 900A has Intel GMA 950 for graphics and I’ve been running into the problem mentioned in in all recent nightlies as well as A4. I’m an absolute newbie to Haiku, so would you please explain how I can see the syslog and remove/change the graphics driver? I’m hoping your fix might work for me too. Currently, I’m stuck in VESA mode, which doesn’t work that well. If I can get this issue fixed, I’m going to install to HD.

Removing the driver is just a workaround to be able to see something on the screen without the annoying interrupted boot sequence.
I’m a bit surprised that this problem arises since I’ve tried a number of recent nightly builds without any problems. I will see if a ticket exists for the ATI mobility 9600 driver.

By the way…the syslog is located in /system/common/var/log/syslog

Darn. It boots fine from a USB. Of course when I installed it on my hard drive the boot loader came up, but didn’t see the boot image on the hard drive. So I’m booted back into the USB right now. I’ll try to repartition the hard drive again. Crossing fingers.

Yeah for grub! Awesome. Up and running. Hey! What happened to stack and tile?

Hi andrewclunn,

S&T is the default decorator and works out of the box, no need to activate it anymore. OPT is the trigger key.


For all you Mac users out there, right-OPT key is no longer the S&T trigger. It has been changed to the left-CMD key…


Hi linuxluvr,

Tank u, after setting SATA RAID to IDE ONLY Mode everything worked fine.
Windows don’t like the Bios setting so i have to cange it always.

Oh duh. I was wondering why it wouldn’t activate. Because it’s already there! Awesome. Dual boot with Haiku on the netbook is a success.

Hi andrewclunn,

I Have the same Problem, Haiku starts fine from USB but not from HD.

need help, how to install grub bootmanager?

OK, I thought I would share my experience with A4 in the hopes that it might benefit someone. I also have had trouble installing A4 and getting it to boot from the hard drive. Firstly, the computer I’m using is a dual core acer laptop with 4gig ram. (I can provide detailed specs if anyone cares). The first attempt to install resulted in no boot loader getting installed. I then attempted to install bootman manually by booting from the cd again - no go. Finally, I had to change the SATA mode in the BIOS from AHCI (the default) to IDE. I then installed haiku again (probably didn’t need to, but I did) to find the same problem - no bootman. However, by booting the cd and manually installing bootman after the OS install completed, I was able to successfully boot from the hard drive.

There seems to me to be a problem with the installation of bootman at the end of the OS installation on some hardware. That is just an observation in my particular case, however.

All of the other hardware on this particular computer works - including the wireless on my WPA2 network - and it worked “out of the box” - no need to install the wpa_supplicant separately.


Maybe the same Problem here?