Alpha 2 on Eee 900

Is it possible to run Alpha 2 on a Eee 900 currently?

I’m looking to do a review of Alpha 2 and would love to be able to run it on this netbook as part of that review.

Currently I am attempting to boot from a usb cd drive (cd burned from the official alpha 2 iso) and it hangs on the fourth boot icon.

Any thoughts?

Toyed around with booting into safe mode but still no luck. Looks like the Eee 900 worked in Alpha 1 but not Alpha 2?

A USB pen drive and the anyboot image would be a better choice.


My EeePC 900A runs Haiku R1A2 very well. I used USB flash drive to install it.

That’s encouraging. So maybe it’s just support for the external USB CD/DVD drive that’s causing the problem. I’ll give it a whirl with a USB flash drive.

Out of curiosity: Is there anything -not- working well with your Eee 900 with R1A2?

I would be surprised if a external USB CD/DVD drive worked.

Followed the instructions here ( to write the anyboot image to a usb drive.

Booted off that usb drive on the Eee 900… and it hangs at the same spot (fourth icon on the boot screen).

Tried it again in safe mode (held down space bar when booting, selected safe mode from the boot options, continue booting). Same result.

Those using a Eee 900: Was there anything else you needed to do to get Haiku Alpha 2 to boot?

For me EeePC 900A works just fine with Haiku. Ethernet, sound, native screen resolution - all works. Wifi not tried.
Boots in 10-15 seconds, is very responsive both OS and software. It is really pleasant to use Haiku on such devices.

What i do, is boot a real CD in a PC that can boot it, then install to the USB pen as you would a HDD. Works every time for me.

I’ve been reading a lot on this discussion board and if I have the answer on how you installed Haiku R1A2 on your Eee 900 (I have a 901), it would solve my problem.

My question: How do I install Haiku R1R2 from a successful USB boot (from an anyboot image)? I have an Asus Eee PC 901.

My problem:

  1. I can’t find the installer to start it manually once I’m booted into Haiku via the USB flash disk.

  2. The boot CD made from the ISO hangs on the last icon, and I’ve tried a lot of combination options in the safe mode including disabling all the ACPI’s I could find per

I’m so excited in starting to learn, tinker around and developing apps in Haiku, but I just need it to work on this netbook.

Any direction that will take me one step closer to my goal will GREATLY be appreciated.

Many thanks,


Browse the Haiku disk (just do a right-click on it’s icon on the desktop) and
go into Haiku/system/apps, you will find Installer.
click the Deskbak’s leaf menu (you know the blue one!), you will find the Installer's shortcut in the “Applications” menu.

Have a nice time with Haiku.


Thank you! That did it. :slight_smile: