Anybody have issues with this? If I have it disabled in the BIOS (which I need for Windows) then Haiku won’t boot regardless of whether it’s disabled in the boot menu or not. If I do enable it Haiku boots fine! Would be nice to be able to boot without having to go into the BIOS config each time!

Using a laptop with a Santa Rosa chipset, sound works, nvidia graphics work nicely, it picked up my USB HDD, loved it. All I need now is a wireless driver, been attempting to compile the FreeBSD one for my hardware (i4965) but no luck so far (though not tried too hard just yet).

At least you can get your Haiku to boot… I’m trying to get Haiku (on my Intel G33BU motherboard) running on /dev/sda2 (I’m using Ubuntu 8.10 to install it) and I’m getting nothing, no matter if I use “Native/ AHCI”, “Native/IDE” or just plain “Legacy”.

Quite just a tad frustrating!

If you Google around, you’ll see that you can enable AHCI after you already have XP installed. Basically, you go into XP with AHCI off (your current configuration, obviously), do a driver update, then reboot with AHCI on. It worked for me, anyways, and I currently quad boot XP, OS X, Haiku, and Kubuntu, all with AHCI enabled.

The following is a link whose directions I followed that is specific for the chipset my laptop has. That said, don’t necessarily follow it verbatim, since you may likely have a different chipset. It should get you on the right track though, seeing as the device manager should tell you your chipset, and you just have to make sure to pick the AHCI version. See the second enumerated list in the first post for directions.


I think having AHCI enabled is the optimal solution. I wish I would have seen your post sooner, but hope this helps if you haven’t solved the problem already.

Oh yeah, and if you have Vista, I’m not sure if anything I typed is relevant. Let’s hope so!

Which laptop is that? I’d like to run os x and haiku on 1 machine!

It’s an MSI Wind U100 (same laptop as the Advent 4211 and the Medion Akoya Mini), which is a netbook. If you’re happy with the small screen and no CD/DVD drive, it’s a handy machine. There is a distribution of OS X specifically made for the laptop called MSIWindOSX86 that makes the installation quite easy. It works well, although I upgraded the hard drive to a 320 GB model (swapped the hard drives between the Wind and a WD Passport), and put a Gigabyte GN-WC06N wireless card into it so I could have wireless in OS X. I believe that there will be a driver soon though for the wireless card that comes with the laptop. Everything on it works in this configuration, although I think you have to mess around with things a bit to get the headphone jack to work. APM won’t exactly work, but using the application CoolBook makes the battery usage better.

On the Haiku side of things, everything works but APM, the wireless, and sound out of the speakers (headphone jack works though). I’m sure the sound will be working correctly soon though as the hda driver matures. No idea if the bluetooth works, seeing as bluetooth is still a work in progress. For wireless right now, I use the USB-powered ASUS WL-330GgE in wireless bridge mode plugged into the ethernet port, and it works well enough around the house.

In any case, to find out more about the laptop, read around on this site:

Thanks, you meant to say ACPI instead of APM under os x?

Do all the important things like suspend to ram and disk work?

[quote=nutela]Thanks, you meant to say ACPI instead of APM under os x?

Do all the important things like suspend to ram and disk work?[/quote]

Yeah, I screwed up my acronyms. I need to keep more current with things. :slight_smile:

Anyways, yes, the suspend to RAM and disk like OS X handles things work as expected. So basically closing the lid to sleep works, and hitting the power button to bring up the shutdown/sleep menu works. I also use the application SmartSleep to tweak how/when suspend to RAM or disk works.

I suppose the only thing you really need a third party app for is for SpeedStepping, since that is apparently handled by EFI. That is why I mentioned the CoolBook application that lets you set how the CPU speed is throttled. (While speaking of EFI, keep in mind that BootCamp needs EFI to work, and as such if you want to run multiple OS’s, you need something like GRUB.)

You’ll be happy to know that the battery gauge works as expected too, allowing you to track time remaining or percentage of remaining battery.

For the record, none of the power-related goodies work in Haiku. I tried enabling both ACPI and APM without any luck. That said, I wouldn’t expect much at this point, so am fine with that for now.

Yes of course if Haiku would support ACPI on any notebook that would make me buy that notebook for sure!

@jprostko - how did you get your MSI Wind to install Haiku? mine errors out when trying to boot.
I’ll have to try playing around with some of the safe boot options tonight, but if I you know of any specific setting that needs to be tweaked I’d appreciate it.