After install, Screen says framebuffer

After I boot Beta 2 on my desktop PC, before I install it, I can run Screen and set the resolution to the full WFHD for my monitor (2560x1080). After install to a local disk, Screen only has the resolution of 1280x1024 and on the left it says “framebuffer”. I guess that there’s a VESA driver running when booting the installer but I don’t know why that disappears after installing. There’s no VESA directory (I forget what the path is where it’s supposed to be, /boot/…? I’m on my Linux laptop right now). How do I get the right driver and setting in the booted system? Thanks!

Edit: forgot to say that I’m using an Nvidia 1070Ti GPU for graphics in that desktop.

Did you boot Haiku with BIOS when installing, but with UEFI after installing?

That’s probably the case. I’m used to seeing both BIOS and UEFI options to boot in the BIOS boot options, but with the USB thumb drive I created for Haiku, I see three (one with just the drive name, “Lexar”, and two more with different partitions of Lexar. Anyway, I don’t recall it saying something like “Lexar UEFI”, so it probably was BIOS.

If it says “framebuffer” (not VESA), you are using UEFI mode. In this case you may be able to change the resolution only from the settings file (in home/config/settings/system somewhere, I don’t remember exactly where it is, sorry). Unfortunately with EFI it is not possible to change the resolution after booting, and our screen preferences don’t work in this case yet.

I think “framebuffer” tooltip is a source of confusion, at least on Telegram this has been asked over and over. I think adding some more to this tooltip should help clearing this up.

Unless it is used for something else why not use ‘EFI framebuffer’ as driver name instead? The tooltip itself could give more details ‘Framebuffer used when booting Haiku in UEFI mode. Resolution change at boot only. See … for more details.’ or an hint to change resolution, the path to the file to modify…

1 Like

It will be used in all similar cases (possibly on some ARM devices when we get that working).

The idea is to show some information about the video card, driver, and display there. But with EFI we just don’t get a lot of info currently (maybe it’s possible to add some more to make this a bit more clear).

The proper fix is not tooltips to give ourlselves excuses about this, but:

  • Write more video drivers so this doesn’t happen too often
  • Even if it needs a reboot to change the video mode, it should be possible to do it from screen preferences