X86-64 nightly iso isn't bootable on mac

Hi All,
I have burned x86-64 hrev54955 iso to make bootable USB for macbook pro late 2008 using this https://www.lewan.com/blog/2012/02/10/making-a-bootable-usb-stick-on-an-apple-mac-os-x-from-an-iso scenario. Booting attempt ended up with blank white screen with no bootable devices presented and machine hangs. If I use a different iso (linux mint) and burn it on USB with the same steps, all works and i get live session


IFAICS MacBook Pro late 2008 had UEFI and our haiku_loader.efi has some known problems with mac versions of UEFI. You can either try beta2 image (which doesn’t have some regressions in haiku_loader.efi) or install rEFInd boot manager and chainload haiku_loader.efi from there.

I have tried the r1beta2-x86_64 image. It doesn’t boot. I am not going to mess up with Clover.

I have MacBook Pro (Retina, 15-inch, Early 2013) and Haiku only boots here via rEFInd.

Ugh, I confused rEFInd with Clover. My bad.

Same problem here. Late 2015 imac. Black screen, then the machine reboots. Really sad.

The latest Mac I have to test is a late 2011 MBP, so idk about a 2015 model. What happens if you boot without EFI (with a legacy/Intel table)?

Same thing happens. Black screen. Nothing appears. Reboots after some time. Weird thing is that i had it working a couple of months ago. Then i tried Big Sur beta and things went south.

So… I haven’t tested anything beyond Mojave with patches (none of my Macs will run 11) but it sounds like it might’ve updated the firmware during the install, I know when updating my MacBook to 10.13.6 it did; I’m guessing that’s why Haiku won’t boot after the update to macOS 11? Maybe try safe boot options and see if it can come up with EFI, again sorry I don’t have anything beyond 2011 — good luck with it!