Working music tracker for haiku?


do you know a music tracker I could use on haiku? (for mod, it, xm and such). Schism tracker is supposed to be compilable but I got errors when trying this, and milky tracker has a binary but while I can start it, when loading a tracker and playing it, nothing is ever played (the cursor is not moving at all)

I’ve compiled last milkytracker version just this afternoon. It compiles with gcc 2.95 after modifying a pair of lines. It loads songs but can not play them, at console output it claims unexpected sound buffer size. I’m afraid this could be a kind of SDL bug. I have no other Haiku system to test :\

where did you get the source code? I can no longer connect to their website

About the sdl error, I have:
SDL: Invalid buffer size: 1248 (should be 4992),

could it be possible to modify this without recompiling the app?

Same problem for me. Tried on real hardware (ac97) and vmware. Buffer size is 1/4 of what it should be. I got the source from that web, but seems to be down since last weekend. I’ve hacked the code to ignore this warning and fill the buffer, but plays quite fast, 4X I guess, so maybe it is real there is a problem with requested buffer. Need some time to track the problem.

I discovered you can change the buffer size on the config options of milkytracker.

Each time the buffer size is different from the buffer expected by a ratio of 4:

SDL: Invalid buffer size: 1608 (should be 6432), skipping…

Maybe forcing the buffer size to be 4 times bigger may solve the problem? (and explain why the speed is 4 times faster when you disable the conditional test)

I tried to compile milkytracker myself, using the code from the Debian repos (

I had to comment this in PPOpenPanel_SDL.cpp:

// this is no longer needed
delete dialog;

fileName = ((result == ReturnCodeOK) ? pathEntry : ""); 

and the same in the PPSavePanel… code.

But even if the compilation when to the end, I got some errors:

runtime_loader: /boot/common/lib/ Could not resolve symbol '_ZNK13BDirectWindow7ArchiveEP8BMessageb’
resolve symbol “_ZNK13BDirectWindow7ArchiveEP8BMessageb” returned: -2147478780
runtime_loader: /boot/common/lib/ Troubles relocating: Symbol not found

(I got my sdl libraries from the tiltos repositories: and I compiled milkytracker both with gcc2 and gcc4)

I just replaced:

fileName = ((result == ReturnCodeOK) ? pathEntry : “”);


fileName = ((result == ReturnCodeOK) ? pathEntry : PPSystemString(""));

gcc 2.95 complains that cant force cast from “” (char *) to PPSystemString, that is what filename expects. Gcc 4.3 compiles without changes. I downloaded sdl-gcc2 from Using sdl-gcc4 I get unresolved symbols too, I guess DirectWindow-gcc2 + sdl-gcc4 are far from compatible. Actually, seems gcc2 the way to go.

Try first milkytracker-gcc2 and SDL-gcc2, It is the only way I got milkytracker running (with no sound)

I haven’t tried to compile it any more, especially if I have to downgrade sdl and such.

Just to tell the website is located on now.

I am interested in compiling milky tracker.I have a question : do we need to compile with sdl lib or making a port without (like PocketPc or GP2X port) ? What is the fastest and the less heavy for our computers ?