Working ftp client GUI in Haiku?

Has anyone got a GUI-based FTP client program to work in any post-R1A4 gcc2 builds? I’ve tried everything from HaikuWare, and the only two that almost work are FtpPositive and Get-It. Unfortunately, both of them either don’t display the connected server’s directory at all, or the server directory that’s displayed is so screwed up it’s unusable.

NetPenguin works nicely. However, due to bug ticket #7785, you have to remove the EXRTranslator from your system to make it work (otherwise it crashes on start).

I’ve been running the hybrid version. I’ll compile the gcc2 version fresh, then see what’s up.

Nightly builds have been messy the last month or so for backwards compatibility, not sure why ATM.

I can confirm. ATM is the only “complete” ftp client on Haiku, with useful features.

I was going to post a ticket on the bug tracker, but it would be a duplicate of two other tickets I found (links below). The problem seems to be the way Haiku responds to another Haiku machine when using any FTP client. I’ll post the last paragraph of this message as a reply to the first ticket in case it might help with tracking down the problem.

So far, connecting two Haiku machines (hrev46033 as host, hrev45164 as remote), I’ve tried FTP Positive, Get-It, NetPenguin, and command-line from Terminal. They all connect but have the same peculiarity of either not displaying the remote files at all, displaying only a partial listing, and/or displaying odd characters for file names. Connecting to a remote BeOS Pro 5.03 machine from the hrrev46033 machine works perfectly… all three GUI clients displayed the BeOS files correctly, and file transfers worked. Reversing it with BeOS 5.03 Pro as local and Haiku as remote, the same problem with no remote files displayed occurs. The Haiku remote files list properly when the host ftp client is running on Linux or Windows.

Once again, I didn’t see any specific bug reports. If you find a BeOS app that doesn’t work, please open a bugreport so the devs can have a look and try to fix it.

The problems with FtpPositive should be fixed if you compile from source: