Workaround to activate audio?

Hi everyone
In a lot of “no audio” threads a trick is mentioned: booting first into an OS that has working sound an then do a hot reboot into Haiku.
I think I could have found another trick hat does something similar without the need for another OS?
I was trying the Test Candidate for Beta 4 on an old laptop, an HP compaq nx7000.
Testing with a pair of video files I concluded that the sound was not working.
Filling the survey I already had put that sound was not working, but while testing the rest of the components I put a music CD I had at hand to test if the optical drive was fine and, to my surprise, when double clicking one of the wav files inside it, the song started to play!
I copied the wav file to the desktop to see if it was a matter of it working just because it was played directly from the CD, but it also worked from there.
Then I opened the same video files that previously played silently, and now they also had sound.
Then I rebooted, tried to play the same files to make sure that audio was again not working, plugged an external usb Blu-Ray drive (to see if the trick can be exportable to other devices that don’t have an optical drive) and the CD spun in the drive but was not mounted, and therefore I could not play it.
I played the video files anyway, and surprisingly sound was working.
So I suspect that it can have something to do with even trying to mount an audio CD?

I still want to try:

  • if it also works from the internal optical drive without the need to play the CD, just mounting it
  • if it also works with an optical DATA disc, not an audio CD, from either drive
  • if sound was already working ok in a previous release and I’m making a fuss about nothing :thinking:

I’m at my workplace right now, so can’t try it and fill a bugreport until tomorrow, but wanted to post this because maybe someone in a similar situation can try this things and see if it’s useful for them.


On my Thinkpad T420, the output-samplerate defaults to 192kHz.
But it only outputs sound when set to 44.1 or 48kHz.
With 48kHz a lot of stuttering occurs during playback.
So in the end only 44.1kHz work.

False alarm.
In the end we have no new “CD trick” for the “no audio” issue.
Trying a few things I discovered that just leaving an audio file playing for a few minutes, sound eventually awakens, late and abruptly, like a noisy friend you didn’t remembered you had sleeping at your house, next morning after a long drinking night.
Booted again later, and just leaving the system alone for a few minutes without playing anything, sound also worked when I tried.
So, nothing to do with CDs, drives or any of that, maybe just some quirk of this particular laptop?
Sorry for the “noise”.

please open a ticket
maybe the sound server awoke too late?



On some machines the driver just needs a bit of time (up to a few minutes) before it starts working. Maybe that’s what happened in your case?

On some machines, the beep from plugging or unplugging the power adapter, all handled by the BIOS, will force the soundcard to be properly configured, no matter what the driver tried to do.

1 Like