Wont boot kdl at HD icon

64bit Haiku,
HP Envy 13-ab016n
it gets to the HD icon on the boot screen and then kdl
I have been trying for an hour to get into the boot options. I have held the shift key down, beat on it like a conga drum. I just can’t get into the boot menu and now I am done. This is to only inform that there is a problem with this hardware. I will try again with Beta 2.

Good Luck

A photo of the KDL screen may help.
Don’t just hope for fixes. (-:

You can also try to get into the bootmenu by rapidly-repeatedly pressing spacebar.

I will try to get a picture. I have also tried the space bar. I have tapped on it like I was trying to kill a roach, but still can’t get to the boot menu.

I think I may know what it is though, at least I suspect. Do you know if Haiku supports NVMe hard drives?

Try holding the SHIFT key on boot-up. Much less hectic than hammering the space bar. :slight_smile:

And no, AFAIK NVMe isn’t supported yet.

Ok,It is probably the NVMe. I have tried holding the shift key, pounding on the shift key. Nothing I do gets me to the boot menu. It used to be easy for me to get to it, but something is different now.