Wireless challenges

I’ve got Haiku A2 on my IBM Thinkpad T42. The OS sees the Atheros wifi card, but the problem seems to be that it jumps onto the first wireless network it sees. In my case, that’s some local ripoff AT&T thing. I’m trying to use MAC filtering + a hidden SSID on my wifi access point and I know it’s working fine because I have a number of other devices working and I have this same laptop connecting via another OS on another partition (NetBSD). At this point I have two questions:

  1. How can I set the network name I want to connect to (SSID, NWID, or whatever Haiku calls it)
  2. How can I make that come up every time I boot?
  3. How can I make the wifi interface primary rather than come up on the intel wireless pro card (or will it always come up on the wifi by default?)

Thanks in advance for any assistance, folks.

Double post…


Works fine on my Acer Aspire One. This answers part of your question.

Turns out that using a hidden “network name” (nwid/ssid) is not supported. I had to turn on “visibility” of the network and then things worked. However, I’m still not sure how to make the ssid static across reboots.