Why is Haiku so slowww on my machine?

Hi all! I’ve been following the Haiku project for about 4 years, and I was so excited the other night to see that R1 is available! I used BeOS in college for an alternate computer “universe” where I could write, check my email, and surf the internet in a different setting and mindset.

I installed Haiku last night and was expecting the agility of BeOS, but everything is incredibly slow on my machine. I’m using a Dell Inspiron with a Core Duo processor, 1.73 GHz, and 1 GB of RAM. Windows 7, my primary OS, runs fine. Haiku should be blazing fast compared to W7, no? What could the problem be? If it means anything, I’m using the CD to boot to my install, but I feel like that that shouldn’t matter.

Tough to really say, could be a number of things. From hardware conflict, interrupt issue, or even BIOS settings. Is this during boot only? Or when running Haiku too?

Try booting with different SAFE MODE options. Hit [space bar] when booting to enter SAFE MODE.

Enable console debug and see where it slows down. Look through your syslog file to find any clues. Hit Alt-SysReq-D and type in ints to check for interrupt issue. Try disabling different things in BIOS.

( SysReq is also your PrtScr key ).

Look through here for some other ideas:

Running Haiku from CD is not optimised. Install it to the hard disk, and the difference will be like night and day.

I also think it is the CD drive.

My desktop computer takes 12 seconds to boot to the Haiku desktop from hard drive, it thats more than a minute if I use the CD, and depending on what I am doing still that sometime to start certain programs on the CD if the program requires additional libraries to load.

Oh, I am using my hard drive install. I’m just using the CD to get to the boot menu, because I haven’t set up bootman or anything else (I don’t know how yet). Still so slow. I’m going to try to use safe mode when I get home from work this evening to see if I can find any conflicts.

@tonestone It’s slow booting AND running. I had the desktop sit to let any background activity finish up for 15-20 minutes last night to no avail. It was still crawling when I came back.

Welcome to Haiku!
What do you mean with crawling? Is it slow when you move windows around? Is it slow starting applications? Is an application/thread using the cpu fully when you look at Process Controller (right click on the cpu usage icon in the deskbar)?

If you want to OVERWRITE your MBR (Master boot record) you can open a Terminal in Haiku (Apllications --> Terminal) type in “bootman” and press Enter.
Now a GUI should appear on your screen and you can install bootman step by step.
But if something goes wrong you may not be able to boot your windows or linux anymore.

Everything is slow. It takes about 10 seconds to open any menu, from the main Haiku “Start Menu” to right-clicking. The mouse moves a little jaggedly. Folders and programs take ages to open. Navigating through menus is delayed by about 5 seconds for each hover, etc.

Looks like kernel and registrar are using the most CPU and memory. Specifically mime in registrar.

e: I installed on an NTFS partition. Could that be a problem?

I am not sure how you installed to NTFS. If you used “dd” or Haiku installer/DriveSetup then you should be fine. The filesystem should be BFS. dd will do this for you but with Installer you need to use DriveSetup to initialize partition to bfs.

You are having some type of hardware conflict/issue. Hard to say what though. You could try turning off DMA in SAFE MODE & see if that does anything. You can also enable console debug and look to see where it slows down when booting.

Did you run “ints” command in debug mode? What was the output?

A jumpy or sluggish mouse may point to an interrupt issue.

Okay, I ran ‘ints’ and came out with a big list of computer speak I don’t understand. I’ll list the basics here:

int… Enabled / Handled

1 1 / 13
5 1 / 0
7 1 / 0
9 2 / 0
10 1 / 0
11 1 / 0
12 1 / 1050
14 1 / 2886
15 1 / 54
219 1 / 195093
221 1 / 18916
222 1 / 0
223 1 / 0

You only need to be concerned with “unhandled”. This number should be 0. The more unhandled interrupts you have, the more it points to an interrupt issue.

Also, you get interrupt #, enabled (saying how many devices using that interrupt), handled - how many were handled properly, what devices are using the interrupt.

Example: Look here:

Interrupt 7, enabled 2 ( 2 devices using this interrupt ), handled 10, unhandled 68 ( 68 were not taken care of ) - used by ehci & uhci ( usb busses ). Report those with unhandled like above.

I didn’t report any unhandled ints because all were 0.

ok, interrupts are not the issue since your unhandled are 0.

In your BIOS, disable pnp and enable legacy usb ( for usb keyboard or mouse ).

Are you using usb keyboard or mouse? Is it wireless? SATA drive? In BIOS, try legacy (IDE) SATA mode. Boot Haiku into SAFE MODE and try those options too.

I had a performance problem on Haiku after updating to a nightly version. I was able to diagnose the problem with the following steps:
Open Terminal from DeskBar
run top

top lists processes that use the most CPU

If you see a process using too much CPU, you can kill it and see what happens (if it’s not a critical system process)

kill -9 (process_id from top)

Whether you do or don’t kill any processes, can you please report back your top processes?

Nothing happens when I type things into the terminal…

Are you using Alpha1 or a nightly? What revision is it? Are you using gcc2 or gcc2 hybrid? ( these are official and best tested versions of Haiku ).

Check again if nightly because recent ones were giving issues and were rolled back. Try a nightly. Very sure r34990 worked well.