What is the setup steps for NetBeans?

I have the latest OpenJDK port (August) and have setup JAVA_HOME, LIBRARY_PATH and PATH correctly to run Java programs.

I downloaded the C++ Module package for NetBeans (OS independent version). Then, I went into the netbeans/bin directory and ran the netbeans shell script. It reported some socket connection problems, came up with the License Agreement and splash screen. After accepting the LA, it exited. I tried again and then the splash screen comes up but then exits halfway through the initialization.

Should I download the OS Independent Java package first and then run that or am I missing something else to get it up and running?


I tried the NetBeans OS Independent Java Package and got similar (failed) results.

[My main interest is to see whether or not their code completion implementation will work well for Haiku C++ development.]

I was able to reproduce the failure and I’ll be fixing it soon. Maybe in the meantime you could try NetBeans version 7.1.2 which others have had success with.


There appears to be a socket connection issue too. Even in NetBeans 7.1.2, try to download some plugins and see if you’re successful. Sometimes it’s okay on the smaller retrievals, but on the larger ones, I get a connection error part-way through the download, keep trying and then keep getting timed out.

There aren’t any new Java exceptions printed to the terminal from where I started netbeans 7.1.2 except the ones I see on startup which complain about an invalid argument:

java.net.SocketException: Invalid Argument
at java.net.NetworkInterface.getByName0(Native Method)
at java.net.NetworkInterface.getByName(NetworkInterface.java:261)
…and so on

I’m experiencing this in a Virtual Box environment with a Nightly gcc2 hybrid build from August (hrev44575 - Kernel: Aug 23 2012 00:19:21). WebPositive has been working fine connecting to various websites even after testing the time-outs from the plugin retrievals.

[But hey…your Java port is awesome! This entire GSOC group has been absolutely stellar!]

Yeah, this port is awesome!

Netbeans 7.1.2 runs slightly better for me. Although there a some problems preventing me from actually building/running a program.
My issues:

  • netbeans won’t start unless I delete splash32.png from the settings folder ( .netbeans/cache/var/ or something).
  • the remote development host thinks it has no write permission in the project folder.

This last one is preventing me from actually building/making a program because it does not create some needed make files. Although it is saying it cannot create the project because of lacking permission, it creates the project files and cpp/h files. But after this I cannot add files to the project. From Netbeans sources I understand that it uses a native process to create a folder (Runtime.execute(“mkdir”)) but somewhere in the process the exit code transforms from 0 to 1. Therefore it thinks the creation of the files failed.
Somebody else experiencing the same problems?

I checked if the process exit code is returned correctly with a simple Java program. This works correctly on Haiku-OpenJDK, so the netbeans problem is more complicated.