Webpositive can't view any webpages in latest (09-Feb-2017) build

Hey there, I’m trying to run Webpositive in the latest build of Haiku (which looks amazing, I might add) but it can’t browse to any web pages - not even local ones.

Any ideas? I tried tailing /var/sys/log but there’s nothing from Webpositive - and the debugger showed no messages.

Please indicate the revision number (from AboutSystem) and HaikuWebKit version (from Web+ about box).
What happens exactly? Does it say something in the status bar? Have you tried running it from Terminal to see if there is something to see there (Web+ sends debug to the standard output, not to syslog). Is your network access otherwise working?

Hey, thanks for getting back to me.

I’m running Haiku hrev50941, HaikuWebKit 1.5.4, and WebKit 602.1.1

Oddly, I switched on my laptop this morning, reconnected to my WLAN and it’s all working fine.

I did see a couple of exceptions caught in the debugger that look like bad invocations of strcmp - can you advise the best way I can get an IDE and GCC checked out and build/run the source myself?


Not sure there’s a IDE around besides “Paladin”. There may be some Qt based IDEs around…
Haiku comes with gcc pre-installed. You’ll have to switch to gcc5 with “setarch x86”. WebKit is available at https://github.com/haiku/webkit, you may want to build with HaikuPorter or at least look at the recipe on how it’s built.

Thanks for your help! I have Paladin working now and am looking through the codebase.

As a newcomer here, I installed -hrev50953-x86.gcc2 yesterday 14 February, and have just tested out webpositive after reading your post - i went to DuckDuckGo and then the BBC news so no problem with this February build on surfing the net - Haiku is very quick to install (or re-install) and that is one way of overcoming that problem - just install the next build (a lazy way, I know, but sometimes quicker than tracking down an issue in an older build).
But half the fun may be overcoming a problem, I guess.

Glad to hear you don’t have any issues. It turned out to be the WiFi card - it’s always had some issues with Haiku, and once I hardwired the laptop to my router there were no more problems!

That’s good. Glad it’s solved.

No need even for that (if the system isn’t irrevertably corrupted). You can update easily to the newest nightly, see Updating your system. You’ll need to reboot after an update.

Thanks humdinger, I’ll try that out soon.

Unfortunately the lack of a browser with better compatibility with Google docs, youtube, etc. I can not use Haiku. NetPositivo always hangs with these services.

I just used YouTube and Google Drive on my tower yesterday, and while they admittedly can end with a debug prompt at times, they do work fairly well. Well – minus the video ads. Not sure why yet, but I’ve noticed they will cause Web+ to stutter and inevitably crash. It’s not perfect, and definitely not as good as Safari, for instance, but Web+ does work for me.