Vmdk stops at splash screen

I’ve tried various versions, hrevr1alpha4-44687 just now, but always the same result: Haiku stops at the splash screen just after the rocket ship icon is lit.

I found this thread - https://www.haiku-os.org/community/forum/haiku_will_not_boot_past_splash_screen - but it hasn’t helped me, it’s more than 2 years old and, if it matters, I’m trying to use the vmdk under Virtual Box (4.2.4 r81684) under Linux Mint.

What am I missing?

I had this issue. Hitting space prior to start up brought up a menu. Turning something of that is on by default allowed me to boot effectively. I forget what the option was. I’ll check it out later when I have time if nobody else responds in greater detail.

Try to disable leave only one cpu as well turn of all other advanced features in VM settings.

Have a look at the last item here:


Ah, replies! That’s encouraging (but it’s a good job I checked back - the subscription feature on this thread isn’t working, it didn’t notify me and still says there are no comments). Now, in reverse order…

@ luroh - Enabling the serial port didn’t made any difference.

@ Diver - I’ve got a very basic config as you suggest although there are a lot of settings and I haven’t been able to try every possible combination yet.

@ andrewclunn - Thanks for the spacebar tip, it brings up boot options and I’ve been able to boot into safe mode. However, the menu blocks at upper right are unresponsive and there is, of course, no Internet connection. I’ve tried most combinations now but I get either this result or it doesn’t boot at all.

Looking at the on-screen debug with a default boot it seems to be stopping after a series of register_domain and unregister_domain function calls. It usually stops at something like register_domain(1, internet).

Further thoughts anyone?

Try to disable networking in VM settings to see if it’s a network driver which freezes Haiku. Anyway, this is still odd because a lot of people use vbox to run Haiku with no problems.