Vm_page_fault error on boot

I was unsuccessful in booting Haiku Alpha 1 release, so have tried nightly builds including the latest one on 1 February 2010, x86gcc4hybrid r35386 but still no success. The boot sequence shows up and process terminates on the third icon. The following is complete screen debug output:

PANIC: vm_page_fault: unhandled page fault in kernel space at 0x10fe8101, ip 0x8188f944

Welcome to Kernel Debugging Land…
Thread 13 “main2” running on CPU 0

code16:0xf000, length 0xffff
data: 0xf000, length 0xffff
heap_add_area: area -1 added to grow heap 0x82000000 - usable range 0x82002000 - 0x82100000
heap_add_area: area -1 added to small heap 0x80219000 - usable range 0x80223000 - 0x80819000
heap_add_area: area -1 added to medium heap 0x80819000 - usable range 0x8081a000 - 0x80bb2000
heap_add_area: area -1 added to large heap 0x80bb2999 - usable range 0x80bb3000 - 0x80e19000
heap_add_area: area -1 added to VIP heap 0x81984000 - usable range 0x81986000 - 0x81a84000
heap_init_post_thread(): created VIP heap: 0x81984000
CPU 1: type 0 family15 extended_family 0 model 4 extended_model 0 stepping 10, string 'GenuineIntel’
CPU 1: vendor ‘Intel’ model name 'Intel® Pentium® 4 CPU 3.00GHz’
CPU 1: features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clfsh ds acpi mmx fxsr sse sse2 ss htt tm pbe sse3 monitor dscpl est cnxtid
initialize_commpage_syscall(): sysenter/sysexit supported
slab memory manager: created area 0xcd000000 (106)
allocate_commpage_entry(3, 5) -> 0xffff0110
heap_add_area: area -1 added to port buffer heap 0x8383a360 - usable range 0x81271000 - 0x81664000
vm_page_fault: kernel thread accessing invalid user memory!
vm_page_fault: vm_soft_fault returned error ‘Bad address’ on fault at 0x8188f944, write 0, user 0, thread 0xd

The PC on which I’m trying to boot is OEM Dell Precision 380 workstation with Intel 955X chipset, 3GHz Pentium D processor, 2GB DDR2 RAM and Nvidia Quadro PCI Express graphics card . BIOS version is A07.

I have tried disabling variety of items in safe mode options menu, and combinations thereof, but no luck. Could anyone suggest what is causing the problem, or even better, potential resolution?


Hi minime.
You should check if there’s a similar ticket already at http://dev.haiku-os.org and register and report the bug there if yours is unique. Make sure to include the revision of your installation.