Vlc 1.0.4?

Hello Everyone,

Currently, one can go to haikuware.com and download VLC which works perfectly, except for the fact that the version is 0.86i. I poked around Google, and discovered that someone successfully ported VLC version 1.0.4 but I cannot for the life of me find a download. I’ve hunted high and low with no success. I tried building the current version 2.0.4 which turned out to be unsuccessful as BASH complained a lot, and I was missing a lot of stuff.

If anyone has successfully built and run VLC 1.0.4 I would really love a copy.

And yes, I know that I should be taking advantage of the already built in media player in Haiku, but I just really enjoy and trust VLC…

Also (super random question) I tried building vlc and my terminal session told me that some resources depended on Lua, which I have installed, could someone tell me [in detail] how to link Lua [if that is the issue] thanks, I really like what’s been done with A4, it’s pretty cool!


I have a test version of VLC 1.0.5 and gave it a test run on A4.1.

Big steps forward. It complains about many things on startup but I could still play a high def MOV video file. Audio was distorted on this and was distorted when I tried to play a MP3.

It seemed to hang when I tried to exit.

It needs work but at least it starts and does something now!