Virtualized Beta 1 locked up repeatedly

I’m working on an article about the Beta 1 release. As part of the article, my boss wants me to create a walkthrough video. In preparation, I installed Beta 1 in VirtualBox on Windows 7. While I was testing it, Haiku locked up several times:

  • When I tried to update Haiku
  • When I tried to install Calligra

I gave virtual Haiku access to 1gb of RAM and set the video ram to 12mb. I installed 32-bit to take advantage of VirtualBox guest additions.

Any idea what could be causing the lock up?

Have you studied the virtualizing guide, esp. the part on configuring the network adpater?
Network trouble may cause trouble when installing big packages.

I found the virtualizing guide just before I had to start work on another project. I’ll try again this weekend.

One thing: When I say the system locked up, I could not move the mouse or get any response.

That’s not usually how that issue presents…
I wonder how that is possible when runnin in a VM. Shouldn’t everyone’s experience be the same? If it were a basic problem of Haiku, everyone would see that. :thinking:

I wonder if it could be an issue with the VirtualBox guest additions. This is the first time that I used them.

Tonight, I’ll try again with VirtualBox on Solus.

Yeah, better try without the additions first.

Last nigh, I reinstalled Haiku without the guest additions and didn’t have any errors. Now to make the video.

1 Like

Great! Feel free to ask, if anything else crops up.