Virtual Box - Boot hung

This is my very first time attempting to use Haiku.

I am running the latest Virtual Box on Centos, it’s running FreeBSD, Ubuntu, and Windows just fine.

I used the vmdk image, when I couldn’t get anywhere I tried the iso install.
It installed cleanly but when I rebooted, I ends up in the same place.

An Initial backscreen screen comes up with a Haiku logo and 7 icons below it.
No mouse cursor appears.

No keyboard or mouse actions seems to have any effect. I have let it sit a day like this with no effect.

This screen appears instantly when booting and just never changes.

What’s going on? do I need to do something? or is it broken?

John L. Sokol

Try the alpha, or a different build.

If using nightly, try Alpha3 which will work. I have used vmdk in VirtualBox and it has worked for me. Could be a bug in nightly image.

There is a post-release addendum that explains what to do. Just enable the first serial port in the VBox settings for your VM. Here is a link to the Addendum:

It worked perfectly for me using VBox 4.1 in Mac OS X 10.6.8.



I’m on OS X 10.6.8 and using VBox 4.1 can’t get passed the boot screen.

I experienced the hanging issue. Enabled the first serial port and booted into haiku successfully one time.

However on rebooting, it’s again hung at the exact same point. The serial port is still enabled. I tried disabling then reenabling, enabling both 1 and 2, still hangs right when all the icons are lit up.

I did absolutely nothing with haiku other than check for network connectivity and reboot. Fresh install. Any idea why it would hang again on rebooting after working once?

Im using virtualbox 4.1.2 on macosx 10.6.8