Via-3058 AC97 and multiaudio

Hi everyone,

When I got my new eMachines box here back at the new year, I can’t remember if the onboard sound worked or not out of the box with BeOS Max (I had to use Max rather than R5 because my R5 CD wouldn’t boot without the AMD kernel patch, and the new machine didn’t come with a floppy drive.)

Anyway, it didn’t take me long at the time to get enough stuff off of BeBits that everything worked peachy, and has been for awhile, until the new multi_audio-addon came out, and I thought I would try it out just for fun. Well, now, the Media preflet gives me options on the inputs and outputs as follows: “None” or blank. Choosing blank crashes the preflet with:

loading symbols
segment violation occurred
BMessage::AddString(char const *, char const *):
+003f ec255243: * 108b movl (%eax), %edx
frame retaddr
fd08198c ec435123 _BMediaRosterP::SaveDefaultDormant(long, dormant_node_info const &) + 000000f3
fd081f9c ec43ea68 BMediaRoster::SetAudioInput(dormant_node_info const &) + 00000024
fd081fb4 80013ead AudioView::MessageReceived(BMessage *) + 00000809
fd0821dc ec307905 BWindow::DispatchMessage(BMessage *, BHandler *) + 000007c5
fd082240 ec3064ee BWindow::task_looper(void) + 00000362
fd08228c ec24efa6 BLooper::task0(void *) + 00000036
fd0822a0 ec0851ed thread_start + 00000039

Now, I’ve tried every combination of the auvia and multiaudio drivers I could think of and find out there, including putting everything back to the way it is on the Max CD and then installing older betas on that. In the less-good cases I only get the option ‘None’ for inputs and outputs, and the good cases I get the two options and crash as described above, but I haven’t been able to get audio again. When I install the non-CVS auvia beta from BeBits, the installer comes up and says it found a device, and I hear a little pop from the speakers waking up at that point. That’s as hopeful as it’s gotten.

What do I do now?


Okay, I found out how to get the audio back…install the older betas of the multiaudio and auvia drivers, then open /boot/home/config/settings/Media and select the 4 or 5 files there, then open the media panel, restart, and as it’s restarting, like after it’s done but before it has started again, delete the selected files.

I never realized this before, but that crashing bug was always there. The difference with this way is, for some reason, the settings default to choosing the blank channel (which works), whereas apparently with the new drivers, it defaults to None. Since there’s no way to change without crashing, you get stuck on None, whereas with the old one you get stuck on blank, which works, even if it looks kinda dodgy.

Hope that helps…maybe you could change the default back?


I have problems with my Ali M5451 chip in my laptop, it only works with ac adapter, now for a while it didn’t work at all, and after I installed Haiku and booted to r5 or zeta to copy some files sound worked ok, weird. In zeta the multimedia addon always hangs when restarting.

I’ll try your method.