USB mouse not working & Atheros Wireless LAN driver

I have two questions:

  1. On my Desktop, an HP a1640n, everything works flawless with the exception of my USB mice. I have two, a Logitech Wireless M215 and a Logitech Wired B100. The Logitech M215 does only works on Windows and Mac OS X (Hackintosh), and does not work on FreeBSD or Linux with Xorg enabled. The B100, however, works on all operating systems, with the exception of Haiku Aplha R2. The B100 works on Haiku Alpha R2 on my laptop, though. Reading previous topics, I have disabled Legacy USB Support, upgraded my BIOS on my ASUS Buckeye Motherboard to the most current version that HP has released which was created by Phoenix Technologies, and have tried enabling and disabling every option in my BIOS configuration setup, such as Plug and Play OS, default video output, etc. to no effect. The PS2 keyboard I have and extremely low quality PS2 mouse I own do work.

2.On my Laptop, a Gateway M7315u, everything works with the exception of the Wireless LAN driver. The card is identified as an Atheros ar928x, which works on Linux (ath9k), FreeBSD 8 (Have not tried 8.1), Windows, and Mac OS X. It is detected as a device and shows up in network interfaces, but when I use setwep to connect to a wireless network, nothing happens. No errors or any output on the command line, it just appears to complete. I have tested and have not been able to ping

Any possible solutions? I would me much obliged.

A few thoughts: Which Linux distro? If the M215 problem happens on e.g. Ubuntu 9.x, but not on say Fedora 13 then that suggests it’s a USB scheduling mishap. CONFIG_USB_EHCI_TT_NEWSCHED is the relevant Linux kernel config FWIW. Re-arranging USB devices can help (which is probably why it works fine on the laptop) and you might try using it via a USB 1.1 hub if you have one gathering dust somewhere, or plugging it directly into the back of the PC if you haven’t already. You will probably also find that removing other bandwidth hungry USB devices can help. Obviously this isn’t acceptable behaviour, but if those things avoid the problem then it means that an OS needs a better USB packet scheduler to get this mouse working reliably. So you could expect that if Haiku USB development continues eventually they’ll fix this without it being specific to your model of mouse.

The B100 might be a similar story with some other lack in the generic Haiku USB stack. There seem to be some long-lived Human Interface Device bugs in Haiku.

I have also noticed something else, whenever I enable Plug & play OS, the underside light of the B100 stays on while Haiku is on, while still not working. But if I disable it, it does not. Also it is the only USB device in the back of the tower, and plugging it into a 1.1 hub had no effect.