Update to latest hrev not working?

Hi all,

So, I’ve been running hrev53286 32-bit on my Dell Latitude E6500 laptop. I tried to use “pkgman update” to update to the latest hrev, and it looked like it did something before the necessary reboot. However, after the reboot, the “About” window still says it’s hrev53286. I tried running “pkgman update” again, and it said “Nothing to do.” I tried removing and re-inserting the repository addresses and then tried “pkgman update” a third time; the same thing happened, i.e. “Nothing to do.” Is the latest hrev (53290 I believe) not in the package repos yet? I can’t see any other reason why the update wouldn’t have worked, unless it’s somehow an issue with my machine.


1 Like

The package repos are lagging behind a bit due to rework of the build infrastructure currently.

In general you can try pkgman full-sync in case some packages needs to be downgraded or removed for the upgrade to work. Do an update first, and then check carefully what the full-sync wants to do, because it could uninstall some of your software.

1 Like

OK, “pkgman full-sync” downgraded my system to hrev53280, but at least it doesn’t get that annoying KDL when it’s trying to boot. Thanks PulkoMandy.

What annoying KDL is that?

The one mentioned here: Hrev53286 (32 bit) does not boot

Yes, I know it was fixed, but hrev53290 doesn’t appear to be in the package repos yet, so I can’t update to it using “pkgman update”.

I have just used SoftwareUpdater to update my software (as you doubtless surmised) and am slightly bemused to find that I now have HREV53368 (64 bit), but when I look at the nightlies page there is no sign of the 64 bit version. The latest HREV is actually 53372.

Should I feel cheated? It’s not very important but I would be interested to know how these things came to pass.

This thing (Haiku) getts better and better. Good to read the article by ProBono.

IIRC, package repositories are generated manually once a week or so, while anyboot images are still generated on every commit.

Thank you.

Any idea why 53368 appears under 32 bit nightlies, but not 64? Has a problem been found so that has caused it to be removed?

No, they are generated every night at around midnight UTC.

Probably the build failed for some reason (likely one of the spurious intermittent failures.)

1 Like

If the build failed, I am delighted to report that it is nonetheless working fine on my Thinkpad. But it’s not important - I was just curoius. Thanks for taking the time to answer.