Unable to find boot partition


#1

I got a new PC, with an Intel Core i7 8700 and a H370 mobo
In my old PC I had Haiku installed from USB and bla bla bla
So, I was going to install Haiku in my new PC, but the installer never loaded, I got the error from the title
I tried with USB 3.0 and 2.0 ports, selected the boot drive from the boot loader, but nothing, the same error
Any ideas?
(I am running the latest nightly build hrev52698 x86-64)


#2

Have you tried the beta? The nightlies can be a moving target. I’m starting to do my testing with both Beta and nightlies.


#3

Yep, I tried
I also tried the ISOs in VMWARE Player, and the same error
I triedto install the OS in VirtualBox (it worked there), copying the system folder to a USB drive, and booting it from the EFI loader in my PC, but I got the same error
I’m thinking maybe it’s the EFI loader, I don’t know


#4

There are a few known issues with the EFI loader:

  • The EFI loader works from the anyboot R1 Beta1 image
    • It only works when the ISO is booted as a “hard disk” (like a flash drive)
    • It doesn’t work when booted as a CD
  • The installed system will not use the EFI loader.
    • It has to be installed manually.

These are quirks of us trying to get the EFI loader squeezed in a the last second. The nightly images are a bet less hacky, and are slowly improving… hopefully R1 Beta 2 and beyond will be a better experience around UEFI.


#5

This is false, the 64-bit nightlies now have it too.


#6

I never said they didn’t :slight_smile: but yeah:


#7

I tried another thing
I put the installer partition on the destination HDD, and booted it from there
The system loaded, but the mouse didn’t worked
Surprise? No
It is USB, so I think it has to be a problem with the USB controller
My mobo is an Asus TUF H370 PRO


#8

The WIFI and BT antenna, the ethernet controller, the HDA device and the UHD graphics card doesn’t seem to work too :frowning_face: (Ethernet and HDA seems recognized by the system, but doesn’t give me audio and networking, and I get video through VESA)


#9

Please paste the output of the listdev command here; that will show what WiFi and Ethernet chipsets you have.


#10

I can’t press Return :frowning:
This computer has only one PS/2 port, and I use the mouse
In the Device app, the Ethernet chip model is shown, but it doesn’t load a driver (Driver: unknown), and it doesn’t know anything about the WiFi, only that it’s Intel


#11

The device app always shows “driver: unknown” (and in fact we removed that line in upto date builds). This is because the app is not able to know if a driver is used or not, it does not mean anything about wether your hardware is supported.

You can drag and drop stuff from the Keymap preflet if you don’t have a keyboard. A bit annoying, but it works!


#12

There is a VirtualKeyboard input device in the tree, but it suffers from being an “input method”, i.e. can only be activated by Alt+Space even when installed. We should make it a normal app, probably…


#13

I suspect that this issue is preventing me from installing on at least 3 systems where I had Alpha 4/nightly.


#14

The new nightly has no problem, so yeah, thanks to team for the fix :wink: