Unable to boot from SD Card

I have created an SD boot card for Haiku using the Anyboot image (after renaming the image type to .img)

When trying to boot the PC from this SD card the splash screen starts but ‘hangs’ before the ‘silicone chip’ icon - which does not illuminate.
I have tried several times and have let the boot process stay there for many minutes (more than 30min) but the system gets no further.

System is an Asus P5K-SE motherboard, 2G of RAM, Intel E8400 Core 2 Duo processor.

Any help would be appreciated.

Hold down SHIFT key while booting or keep pressing SPACEBAR when booting to enter safe-mode. Try out those options and hopefully you can boot.

The first time, enable them all and choose 800x600x32 for resolution and see if you can boot. If yes, then you can try to figure out which option(s) is required for you to boot Haiku.

It freezes on people for different reasons, usually graphic driver (use vesa - fail-safe graphics), network conflict (wifi vs wired), drive controller issue, etc., …

Many thanks for the reply tonestone57 -

Unfortunately I am still unable to boot Haiku from SD card even after trying your recommended ‘safe - mode’ settings and almost every other combination available after using ‘shift’ or ‘space bar’ during the boot process.

I have tried re-writing the SD card but still no luck.

I have also tried setting my motherboard bios to ‘OS = Non-Plug&Play’ as the old BeOS could sometimes have a problem with this setting but -
still no luck !

Although I am not a technical person, this looks like a ‘system problem’ so I don’t believe that blowing a boot CD would fix the problem either.

Any other ideas ?

USB “thumb drives” are cheap. Try one of those instead. Unless your BIOS has a setting specifically labeled “PC-CARD” in the boot order menu, chances of getting a SD card to work are slim and none. I did it once in Puppy Linux but it was a chore.

I actually boot Haiku off SD Cards, a Crucial & Kingston. For the Kingston I had to actually raw write the image to the card because would not boot otherwise.

For almost all issues, using safe-mode options will allow you to boot into Haiku (checking all or some of them). Except for ATA stack which requires building image with IDE stack. You will find link to 3rd party (non-hybrid?) images with IDE stack here:

When you selected fail-safe video mode you also set the resolution too? You need both of these options for VESA to work.

Try on-screen debug mode to see what is going on. Actually better if you can get your syslog to look it over. Read, near bottom, Syslog section onwards: