Trouble Loading Haiku from a USB drive with Windows 8 and UEFI

I just found out I have the UEFI problem. Secure boot is enabled. I want to run the live version through a USB to test out Haiku. My main problem so far is i cant get my USB drive to show up in the boot options menu at startup. This led me to research and find out about the new UEFI i have apparently. I have previously followed the steps to setting up Haiku on a USB stick from here:

I have seen this thread but dont know how much of this applies to me:

I have 3 major questions as outlined below.

My Bios does give me the option to disable Secure Boot and it also tells me that I will not be able to load windows. Is it safe to disable secure boot, run the live Haiku from USB ( provided i can see it as a boot option) then go back to windows 8 by re-enabling the secure boot option? I want to be sure this wont screw up my MBR or whatever UEFI is using before I try it.

Also, if i wanted to install the os to a partition on my hard drive for extended testing, how would the UEFI stuff interfere with the procedure to install Haiku as stated here: Or here: ?

Would something like This EFI Bootloader help any but made for Haiku:

Thank you, I look forward to your answers.

I’m not going to comment on the secure boot issue.

However; I would NOT recommend installing Haiku to a disk that currently uses the UEFI GPT (GUID partition table). I don’t believe that Haiku is in any way aware of the GPT scheme, and would likely trash your GPT disk setup if you tried to install Haiku to a drive that used a GPT. I think I have seen another member’s thread on this forum, about a three-times-around-your-back way to mix-and-match Bios and GPT. My experience with mix-and-match has been relatively poor. Not everyone has standardized on the same “hybrid” specification, from what I understand. I would suggest not to do it, and to make sure that you have good data backups if you proceed anyway …

I Have disable the secure boot and I boot Windows 8.

I think Haiku now support GPT but I haven’t tested yet an don’t know how mutch…
But It’s on it’s way :slight_smile:

When It comes to EFI you probably can switch in bios to a legacy mode?

I hade problem booting USB I used a USB CD in a USB3 port (the USB2 didn’t work)