Touchpad input panel doesn't let you change focus mode?

It looks like Haiku supports focus-follows-mouse mode, but the option is only in the Mouse preferences panel (part of Input):


However, I don’t have a mouse; I have a touchpad. The option isn’t available there. (I can’t find a screenshot of the current version of the setting panel, but it’s essentially the same.)


Is there any other way to change this setting? Also, this feels like a bug.

You can switch with the ffm command.

Yes, this is a limitation of the preference panel design. The setting is in fact global, and should be moved out of the mouse specific preferences, maybe to some global “pointing devices” section.

Since this is a bug, can you report it at instead of using the forum? Thanks!

Done; it’s Thanks very much!