Touch Screen causes mouse problem


#1

When I was in Cuba my mouse under Windows 10 would act funny at times, moving without input or refusing to move.

After a while I figured out that the touch screen was causing the problems when the air got too humid.

Since touch screens did not work under my version of Haiku I never noticed any problem with it. But just before coming to Florida I did a major upgrade using the nightlies.

It took an entire day fighting with machine before I remembered what happened in Cuba. Looking at my Haiku drivers directory I zero onto the Wacom driver.

Once I blacklisted the driver my computer has been running as normal.

Hope this help someone.

Note: Theproblem is in the hardware since I have seen it in both OSes.


#2

AAARRRHHH. I Blacklisted the Wacom and Tablet drivers in the ~/config/settings/global directory. But after reading the web page again about Blacking I found out that only affect User-Addons.

To Blackliast system drivers I need to add the ‘packages’ file to /boot/system/settings but that is a read-only protected directory.

Does anyone know how to add a package file with recompiling the OS?


#3

The /boot/system/settings directory is writable, you can just create your file and then copy it in there.


#4

Thank you, it worked. I don’t know wht I did wrong before when it said it was a read-only directory but this time the packages file copied on the first try.

Again thanks.


#5

Tracker still has a warning that this is a system folder (“use with caution” or so), but you can write to it.