TokuToku ( BeGadu )


#1

Hello, how to install TokuToku? https://github.com/HaikuArchives/TokuToku

I don`t see it in depot.


#2

there is no recipe for it at Haikuports. PRs welcome!


#3

So what to do now? I`ve cloned it with

git clone https://github.com/HaikuArchives/TokuToku

however I dont know what to do now. After entered that location I entered "make", but it didnt worked (I guess no make file there). Any suggestion?


#4

Apparently, it uses jam files instead of makefiles. You have to type:

jam


#5

apparetly, there are some bugs in the code:

image


#6

Yes. I have x86 nightly and get errors too. Hm, bad. :-/ Seems that last update was at 2015, and Haiku changed api or something like that, so it don`t build any more.


#7

I’ve fixed (or at least I think I have) the errors relating to Haiku API changes and some 64bit issues. Now the program compiles but it doesn’t link because it needs libgadu. So I downloaded that and tried to compile it. ./configure completes, but when compiling the library there are errors in the example. The code is in plain C, so it’s a bit above my head I guess :wink: But I will take a look at it again tomorrow if I find the time.

In any case, I will make a pull request with my changes to TokuToku tomorrow. Maybe somebody wants to jump in and help with the library.


#8

Ok, here we go…

I got libgadu to compile on Haiku and TokuToku to link with it. The application starts with some sort of profile create dialog. That’s as far as I could test it due to my virtually non-existing knowledge of the Polish language :wink:

@General_Edmund_Duke:
Here is roughly what you have to do to compile TokuToku at the moment.

  1. Get the source code of libgadu from http://github.com/wojtekka/libgadu/releases/download/1.12.2/libgadu-1.12.2.tar.gz and unpack it.
  2. edit the file examples/conn-async.c and add #include<sys/select.h> near the top of the file where the other include statements are.
  3. configure the source with ./configure --prefix=/boot/system/non-packaged/develop --includedir=/boot/system/develop/headers
    At the end of the configure process the activated options and used libraries are displayed. I don’t know what is actually required for libgadu and TokuToku to work correctly but I installed as many of the missing libraries as I could with pkgman. On my system those were gnutls_devel and expat_devel,
  4. Compile and install the library with make and then make install
    After that you have to copy (or symlink) libgadu.so.3 from /boot/system/non-packaged/develop/lib to /boot/system/non-packaged/lib. If you don’t do this TokuTuku will compile and link but not start because it can’t find the library.
  5. Get the modified TokuToku source code from my cloned github repo with git clone https://github.com/andimachovec/TokuToku
  6. Compile it with jam -q

That should leave you with a hopefully working TokuToku executable.
Remember that since you are on 32bit Haiku you have to switch the compiler environment to gcc7 with setarch x86 before you do anything compiler related in the Terminal. Otherwise you will use gcc2 and all sorts of strange stuff may happen :wink: Also the library names in pkgman are different, you’ll need the ones ending with _x86 i think.

Well, that’s all for now, hope I didn’t forget anything. Feel free to ask if something isn’t working.


#9

Thanks man! Ill try it as soon as Ill arrive home!