This one gets me pulling my hair! (no-go on Acer Aspire One)

A while back I had created a Haiku USB Key with Alpha R3.

I have successfully booted several Thinkpads and a Dell laptop using this key.

However, I`m getting stuck just before the Disk icon lights on.

The Acer is Aspire One 721-3922 (Windows 7).

Using Debug Option under Safe Boot, the last message from the displayed is:

USB ehci - 1; The USB Controller is bios owned, claiming ownership.

Has anyone encountered similar issues and successfully resolved them?

Note that I yet to successfully boot from a linux LiveCD - for example SystemRescueCD.

why not try Haiku Alpha release 4?

I have searched for a ChangeLog for R3 to R4 and R4.1 from which I could assessed if there has been changes to the USB subsystem and thus hope that going to R4.1 would fix the issue. However, no luck in finding such a ChangeLog. If one exists, can it be made easier to find?

Assuming that R4.1 fixes the issue, then how best to transfer the stuff currently residing in the /Home folder of my current R3 USB Drive to the new one?

The issue I have encountered with SystemRescueCD does not appear to be related to the USB subsystem on the Aspire One. This is a good sign as this suggests there is hope.

However, it appears that this (halt with cannot find /sysrcd.dat message) has been present since the 1.5.4 release and occurs when booting from an external USB optical drive. A work-around seems to exist but it involves adding kernel modules and burning a CD-ROM with the resulting customized /boot folder. This was not expected from a system rescue tool implying it is bootable from a CD-ROM and an external USB optical drive is such a device for a netbook. It is infuriating given that this is still an issue with the current release 3.7.1!

The issue has been partially resolved.

I grabbed the R4.1 image and installed it directly on an USB key using DiskImager (Windows). I booted it and crossed my fingers as there was a slight pause … before the Drive icon lighted up.

This now leaves un-answered the question of the transfer of my /home from the R3 USB Key to the new R4.1 one.

I am still puzzled by the difference in behavior with respect to the USB boot between the two releases.

The key intended for this had to be re-partitioned. It was a 4 Gb USB key portioned into two halves - one for FAT32 (accessible from Windows) and one for a bootable Haiku R3. A good idea which I unfortunately could never get to work. Feeling safer with GParted, I used LinuxLive USB Creator to get SystemRescueCD directly onto an old 512 MB USB Key. This worked well.

Never easy to explore beyond Windows using a Windows only system!

Have you tried one of the gcc2 hybrid nightly releases?

Do you only have the one USB key?

If not boot with the working unit, then plug the other key in another port, you can open it from within Haiku-OS, then copy the home files by hand. Or rename the home folder on the second drive, drag it over to your present booting key. Quickly rename you home folder, rename back to home the folder you dragged over then reboot.

Otherwise, take that 2GB key which I assume you used an any-boot image to create, use drive setup to create a second Haiku partition to put the other copy of Haiku on or only copy the home directory. Assuming you have 600+ MB for the any-boot, create an 1 GB Haiku work partition and assign the rest to FAT32. You do all this from inside your bootable Haiku using DriveSetup then use Boot-Manager to allow to select the boot partition.

Personally, on a 4GB USB stick I usually end up with 3 boot-able Haiku partitions and one FAT32 partition just to be flexible.

Give it a try, Haiku-OS already has all the tools you need.