Testing the latest images wth qemu-system-x86

Debian 9 on Xiaomi Air 13"

when I download various latest 64 bits anyboot images, extract the iso and launch

sudo qemu-system-x86_64 -cdrom haiku-nightly-anyboot.iso

It fails with
Haiku: Panic: did not find boot partitions

with some older iso like
hrev52300

it boots, displays the seven images of the Haiku logo, and hangs

Thanks for any hint

Hi! Welcome to Haiku.

Well firstly, as a guy who runs qemu often, why invoke sudo? On Haiku, you don’t need it, and on Debian Gnu/Linux (which I’m seeing you’re using as a host) you also shouldn’t need it here. If it’s kvm acceleration you need, create a kvm group and add yourself to it – if your distro didn’t do that for you anyway. You shouldn’t need sudo unless you’re doing something like accessing raw volumes, such as -hdb /dev/sdc, for instance.

Now, the other thing is that you’re starting qemu in full ‘automatic’ with no options, like cpu, etc. That’s fine, but you will need to specify a few important options to it:

  • -m 1G: While Haiku can get by with very little memory due to its excellent design, I usually give it plenty just in case I want to run a lot of applications inside a session. (The default amount, iirc, is 128 MB, which probably won’t get the 64-bit edition up.)
  • –enable-kvm. Hint: There’s two dashes here. If you’ve got hardware acceleration with kernel virtualization support on your distro, use it.
  • -boot d: If you’re booting from a CD-ROM, it’ll most likely guess this one like the other options, but this might just help.

Also, hrev52300 is not all that old. The current Nightly is 52302 as of this writing; the x64 Nightlies page is here.

thanks

using

 qemu-system-x86_64 --enable-kvm -m 1G -cdrom haiku-nightly-anyboot.iso    

it boots fine

qemu-system-x86_64 --cdrom haiku-release-anyboot.iso -m 2048 --enable-kvm --usb -device usb-tablet is a good combo. The usb-tablet emulation makes the mouse a lot easier to use in qemu.

Definitely agree with the -device usb-tablet suggestion. I’d forgotten about that one. Also, exporting SDL_VIDEO_X11_DGAMOUSE=0 in your shell window before running qemu on Debian may help as well. I’ve also found using a trackpoint or nub works better than a trackpad for moving the mouse pointer in virtual environments.