System locks up while building haiku


#24

I’m not seeing the option to save, as the docs are showing should be there. Would /boot/system/var/logs/syslog.old be appropriate? It appears it is already setup to save there.


#25

syslog.old is the rotated syslog after it gets too big. previous_syslog is the syslog saved from the last boot, if it could be recovered. So if you have that, it may have what you want.


#26

My previous_syslog is dated back to November. I’m not sure it is setup properly.


#27

I don’t seem to have the option to do a warm reboot on my system. I can only power off then back on…


#28

So, I ran into some “hard lockup” issues while working in the new ipro1000 driver that I eventually tracked down to a programming error on my part – I’d forgotten to set the B_DO_NOT_RESCHEDULE flag when calling release_sem in an interrupt context. This meant that the kernel could legally reschedule that thread, and as the kernel-wide hardware interrupt lock was held in that thread, this then prevented interrupts from being received at all, which of course also prevented the KDL keyboard shortcut from functioning.

I added an assert to the kernel in hrev52724 which will turn such problems from hardlocks into panics; so if there are any of these lingering around the tree in less-used drivers, this should expose them. So please retest and see if you get panics now.


#29

As of hrev52729, I still get hard locks at build time. The hard lock on shutdown is still present, re: ticket #14718.