System freeze, hw or sw fault?

I was testing a machine I wanted to give for free to a friend:
Phenom II X1075 8GB DDR3 RAM SSD samsung evo 840 128GB GeForce GTX 660 Mobo ASUS M5A99x EVO, PowerSupply of about 425W.
I wanted to use phoronix-test-suite but php is missing in haikudepot. So, just for fun, I downloaded php 4.7.4 and launched ./configure to compile it (or at least to try to compile it), but soon after pressing enter, the system froze completely. I rebooted and repeated the command, and again it froze.
I though a ram error so I used memtest86, but ram was ok, so I ran (under windows) a cpu stress test, and again a gpu stress test. No errors and no system locks/freeze.
but every time I launch ./configure under Haiku the system halts.
smartmontools say ssd is ok, I tried to download again php and compile it in another directory, without luck.
If I try to launch ./configure on other machines (same haiku x86_64) there are no system abnormalities.

I have no evidences that this is a software or a hardware fault. What do you suggest, anyone there with a phenom II? I’m not sure about this system because the previous owner (my nephew) reported that the system is freezing sometimes, but I found and removed a faulty Hard Drive.
Any help or suggestion is appreciated.

Haiku has some known problems with certain AMD chips, see #15817 and #14082, for example. Maybe yours has similar issues.

I’m curious, why such an old version of php? From my experience the build process of php is quite quirky and I wouldn’t be surprised if they managed to freeze everything.

There is a recipe for php 5 (and I think 7, now) in haikuports. It has not been made into a package because one of the things in their configure script crashes, and the buildbot gets stuck on it waiting for someone to do something with the debug prompt. But if you build it yourself from that, it should work (at least it did last time I tried).

I uploaded recipe for PHP 7:

@PulkoMandy Oh boy! Sorry, I inverted the numbers it was 7.4.7 :sweat_smile:

@humdinger thanks for addressing me to these tickets, it’s a pity that this machine has such problem, I wanted to give this pc to an IT student (in hope that one day he would contribute to Haiku)

@X512 thank you for the recipe

Does it work for you now? I mean the php 7.4.3?
Just asking

well, I git-cloned haikuports and haikuporter (because in beta2 I could not see any php package in haikudepot) and soon after launching haikuporter the system froze. So, no.

Known issue, but get the hardware professionally checked and cleaned. Never hurts to do that.

There is a recipe and patchset for PHP 5.6.37 and PHP 7.4.3 here. Download the patchset and recipe in the Haikuports PHP directory within your copy.

PHP 5.6.40 and PHP 7.4.7 are the latest PHP releases.

Has anyone got the Phoronix Test Suite running under Haiku?

There is a ticket for official Haiku support.

Oh nice. Besides official support, has anyone been able to get it working?

It seems that there’s no bug/freeze with the same hardware in haiku x86_gcc2

PHP 5.6.37 installation from haikuporter halts after finding zlib and checking zlib install directory (indicated as /boot/system)
7.4.3 cannot be installed in haiku x86

You can check with the Haikuports admins to review php compilation on the buildbots.

For the AMD hardware issue, see if anything you did before still causes a reboot/halt/or crash using Haiku x86 only.

I’m having the same freezing/shutdown problem. I have an AMD FX 8350 CPU. Running Beta 3 x86_64 (Revision hrev55181+54). I really think this should be a critical level bug, IMO. I tried booting with the safe mode option of “Ignore memory beyond 4 GiB” (after reading ticket #14082), but that didn’t help.

Edit: I’m also affected by ticket #14887.

If you think you are affected by one of the bugs mentioned above (or a new one), please update trac with any relevant logs and information so we can continue looking into this.



Haiku R1B3 x86_gcc2

  1. pkgman install php_x86

This downloads php_x86 7.4.16-2. No issues in downloading. Latest is: 7.4.22

There are x86 and x86_64 PHP packages. Seems PHP 7.4.16 builds on the buildbots.
PHP 7.4.22 built fine on my workstation.

Note: As with Phoronix Test Suite 10.4.0 on UNIX-compatible operating systems, the principal dependency is on PHP (PHP v5.3 or newer, including PHP 7.x).